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INTRODUCTION
This User Manual contains description of operation in the AutoGRAPH 5 PRO Dispatch Program, 
version 2015.11.21 (revision 134), developed by TechnoKom LLC.

This Manual is designed for experienced specialists familiar with basic principles of satellite 
monitoring system operation. Knowledge of C# programming language fundamentals may be 
required for setup of some modules. To develop your own AutoGRAPH 5 PRO modules, you may 
use any language which supports development for .NET (such languages are listed on website 
http://www.dotnetlanguages.net/).

AutoGRAPH 5 PRO is a multi-functional dispatch software based on the separate modules, which 
may be combined into a unified system. The main advantage of this system is possible integration 
with other systems and building dispatch software of any complexity meant for both ordinary and 
advanced users. A great advantage is the fact that advanced users may develop their own modules 
and implement them in the AutoGRAPH 5 PRO program. 
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AUTOGRAPH 5 PRO SOFTWARE 
DOCUMENTATION LIST
This section contains the list of all documentation related to the AutoGRAPH 5 PRO Dispatch 
Program.
•	 AutoGRAPH 5 PRO:  Quick start is a short instruction on installation and quick setup of AutoGRAPH 

5 PRO software: creation of a device list, server setup, track building and monitoring of the main 
vehicle operation parameters.

•	 AutoGRAPH 5 PRO User Manual is a document containing description of the basic functionality of 
the AutoGRAPH 5 PRO Dispatch Program, including installation and pre-configuration of the 
software, working with schemes, setup of interface and desktop, creation and setup of vehicle 
list, setup of data sources, object movement monitoring, plotting a track, trips, track segments 
and diagrams, multitrips and mobile check points, automatic route determination, operation in 
Monitor module, processing photos, detailed analysis of AutoGRAPH device entries, etc. 

•	 AutoGRAPH 5 PRO: Data processing and calculation – the document contains an instruction for 
creation of new calculation parameters, setup of standard parameters in Designer, setup of data 
filtration and correction before calculation.

•	 AutoGRAPH 5 PRO: Drivers – the document contains an instruction for creating a list of drivers and 
setup of driver identification based on personal and tachograph cards, and an instruction for 
generating reports on each driver’s trips.

•	 AutoGRAPH 5 PRO: Geo-fences – the document contains comprehensive instruction for operating 
geo-fences in the AutoGRAPH 5 PRO Program: creation, import, setup, operations in Editor of 
check points and polygons, creation of reports on passed geo-fences, setup of geo-fence passing 
processing.

•	 AutoGRAPH 5 PRO: Map Viewer – the document contains an instruction for preparation and loading 
of maps into the AutoGRAPH 5 PRO program, as well as their setup and description of operations 
with the module tools. 

•	 AutoGRAPH 5 PRO: Reports – the document contains an instruction for creation of quick and 
detailed reports, as well as editing report templates.

•	 AutoGRAPH 5 PRO: Field processing – the document contains an instruction for creation and setup 
of field processing tools, creation of field geo-fences, generation of trip reports and reports on 
operation of agricultural vehicles on the fields (processed field area calculation).

•	 AutoGRAPH 5 PRO: User Manager – the document contains an instruction for managing users on 
AutoGRAPH server using User Manager module which is integrated into AutoGRAPH 5 PRO 
software, loading of files by users and message communication between Dispatcher Program 
users.

•	 Note to the AutoGRAPH 5 PRO Program: Data import from the AutoGRAPH Dispatcher Program – the 
document contains an instruction for importing data from AutoGRAPH Dispatcher Program 
versions 3.5 and 4.0 into AutoGRAPH 5 PRO.

•	 Note to the AutoGRAPH 5 PRO Program: Solution for cranes (ONK-160B, ONK-160S) – the document 
contains an instruction for processing the data received from ONK-160 unit of tower crane and 
jib crane in the AutoGRAPH 5 PRO Program. 

•	 Note to the AutoGRAPH 5 PRO Program: Passenger Traffic Scheme data (IRMA-MATRIX) – the document 
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contains description of operation procedure in the “Passenger Traffic Data (IRMA)” scheme of 
AutoGRAPH 5 PRO Dispatcher Program designed for processing of the data received from IRMA 
passenger traffic sensors connected to AutoGRAPH on-board controller. 

•	 Solution for tachographs: AutoGRAPH-GSM-Drive module: the document contains description of the 
procedure of AutoGRAPH-GSM-Drive module setup and connection, and processing of the data 
received from the tachograph using that module, in the AutoGRAPH 5 PRO Program, including 
Tachograph module designed for generating reports on ddd files.
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THE LIST OF THE MAIN HOTKEYS
This section contains the list of the main hotkey combinations used in the AutoGRAPH 5 PRO 
Program.

The terms used in this document and in all related documents denoting actions performed using 
mouse are detailed below.
•	 Left click is a single left mouse button click.
•	 Double click is a double left mouse button click without long pauses between clicks.
•	 Right click is a single right mouse button click.

HOTKEY LIST

Key combination Description

Operations with the scheme
Ctrl+S Save the current scheme

Ctrl+L Open the “Load files from server” menu

Desktop
F11 Go to full-screen view

Ctrl+Alt+Down Show entries list (Data Viewer)

Display different menus
Ctrl+O Display the “Options” menu

Ctrl+D Display the “Devices” menu

Ctrl+G Display the “Geo-fences” menu

Ctrl+R Display the “Drivers” menu

Ctrl+I Display the “Implements” menu

Ctrl+T Display the “Tasks” menu

Operations available in the modules
Left click Highlighting an object / entry / point on a track.

Right click Call of the selected object’s / module’s shortcut menu

Mouse wheel rolling Changing scale in Map Viewer 
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GETTING STARTED
SYSTEM REQUIREMENTS

Parameters
Minimum system 
requirements

Recommended 
system requirements

Operating system Microsoft Windows XP SP3 Microsoft Windows 7

Processor Intel Core i3 2 GHz Intel Core i5 2 GHz or higher

RAM 2 Gb 4 Gb

Free disk space 150 to 200 Mb free space on a hard drive (without data to be loaded)

Screen resolution 1680х1050 pixels 1920х1080 pixels

Internet connection When using Internet maps and for data loading

Installed software  .NET Framework 4.0. 

SOFTWARE INSTALLATION
Before installing make sure that the computer where the software will be installed meets the 
system requirements. 

Load the distribution package from the official website or official forum (in case of a test version) 
of TechnoKom LLC prior installation.

To install AutoGRAPH 5 PRO, an Internet connection is necessary as during installation the program downloads 
installation files, demonstration schemes, demonstration data and other files necessary for correct operation 
of the program from the server. 

IMPORTANT

Installation procedure:
Step 1. Run the installation file AutoGRAPH5_Setup.exe and select the program language. The 
Welcome screen (Fig.1) will open, click the “Next” button. 
Step 2. Before installation you will be asked to accept the AutoGRAPH 5 PRO License Agreement. 
Read and understand the agreement. If you agree with terms and conditions of License Agreement, 
accept it and continue installation. Otherwise, it is recommended to interrupt the installation. 
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Step 3. The installer will suggest selecting the folder into which AutoGRAPH 5 will be installed (Fig. 
2):
•	 Default install – allows installing the program into the default folder: \Program Files\AutoGRAPH 5. 

In this case the program configuration, such as schemes, lists of vehicles and geo-fences, drivers, 
etc., will be stored in folder \ProgramData\AutoGRAPH Shell, and user files, such as maps, files, 
photos, including data received from AutoGRAPH gauges, will be stored in OS MS Windows user 
folder Users\<user_name>\AppData\Roaming\AutoGRAPH Shell.

•	 Select the Destination Folder Manually – allows selecting a custom folder for the program 
installation. To select a folder, click the “Browse” button. When the “Next” button is clicked, the 
program will offer selecting also a folder for storing settings and data (Fig. 3). 
Standard: the default folders: the program is installed into the selected folder. With such setup the 
scheme files will be stored in the default folder \ProgramData\AutoGRAPH Shell, and user data 
and files will be stored in folder Users\<user_name>\AppData\Roaming\AutoGRAPH Shell.
Standalone: the settings are stored in the program folder: the program is installed into the selected 
folder. The user files, data, program configuration (schemes) will be loaded into the same folder. 
The data will be stored in the folder \User\Data inside the selected folder, scheme will be stored 
in the folder \Common. 

•	 Install in user folder: allows installing the program into the current system user folder. In this 
case the program, data and settings will only be available for the current user who logged in 
the computer operating system. With such setup the program is installed into the folder C:\
Users\<user_name>\AppData\Roaming\AutoGRAPH 5. The data is loaded into the folder C:\
Users\<user_name>\AppData\Roaming\AutoGRAPH 5\User\Data, scheme files are stored in the 
folder C:\Users\<user_name>\AppData\Roaming\AutoGRAPH 5\Common. 

•	 Step 4. Select modules which should be loaded and installed (Fig. 4). 

Fig. 1. Installation beginning. Fig. 2. Folder selection.



AutoGRAPH 5 PRO • USER MANUAL12

TechnoKom © 2016

Fig. 3. Settings storage folders Fig. 4. Items for installation

Step 5. Click the “Next” button to continue the installation. The program installation may take some 
time, wait for its completion. The installation completion window will appear once the program is 
installed. This completes installation of the AutoGRAPH 5 PRO program. 

Before using the AutoGRAPH 5 PRO Dispatcher Program, it is recommended to familiarize with the basic terms 
which are used in the Dispatch Program and documentation. The basic terms are listed in the “List of Terms” 
section of this User Manual.iNOTE
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PROGRAM OPENING AND SCHEME 
DOWNLOADING
This section contains an instruction on the first start of the program, opening of the required 
scheme, authorization in the program and downloading of the required schemes from the server.

PROGRAM START AND SCHEME OPENING
Before starting make sure that the AutoGRAPH 5 PRO Program is installed on the computer. If the 
program is not installed, it is recommended to install it following the instruction described in the 
paragraph “Software installation” (see the “Getting started” section).

Then proceed as follows:

•	 Start the AutoGRAPH 5 PRO program. 
•	 A scheme used by the user during the previous session will be automatically opened together 

with the program. If the program is started for the first time after installation, a demonstration 
scheme will be automatically launched (if installed). 

•	 If for some reason no scheme for launching was found on the disc (the scheme was deleted, 
relocated, uninstalled), a blank scheme template will be loaded. In this case, it is recommended 
to load the required scheme manually. For this purpose, choose Menu bar > Scheme > Open and 
select the required scheme in the drop-down list (Fig. 5). 

Fig. 6. Entering the server. 

This list displays schemes located in the folder \
Schemes available in the program system folder. 
The folder for scheme storing is set at the program 
installation stage. 

•	 In the AutoGRAPH 5 PRO program, a user authorization system is operating, that is only registered 
users have access to the program functions. Once the scheme is loaded, the program will request 
a login and a password to obtain access to data on the server. The parameters of the accessed 
server are specified in Server line of the authorization window (Fig. 6). 

Fig. 5. Scheme Loading.

The “Remember Me” option makes it possible to save the current server 
logging parameters and not to re-request them upon each start of the 
program. The stored passwords may be changed in the “Options” menu in 
section Servers > Downloading and saved accounts. Server parameters may 
be set in the “Devices” menu in the section Servers > Server, password for 
device. 
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Fig. 7. Scheme loading from the server.

The schemes which have already been loaded 
to the local disk are shown in bold type.

Upon entering of the correct login and password, connection to the server will be established, and 
all data available for the user will be downloaded. 

The user account is created on the server from which the program requests data. A list of gauges to which the 
user will have access is created for each user along with the account. To get login and password for the access 
to the AutoGRAPH 5 PRO program, contact your dealer.
A demo version with test data is provided to review the basic features of the program. To log into demo version 
of the program, use login “demo” and password “demo”.

iNOTE

SCHEME LOADING FROM THE SERVER
A scheme of the AutoGRAPH 5 PRO program may be loaded from the server. A user’s schemes 
accessible to the user with other user files may be stored in the user folder on the server. To 
download a scheme from the server, select Scheme > Load from server in the main menu of the 
AutoGRAPH 5 PRO program, or press the “Ctrl+L” key combination. The “Load files from server” 
window will appear (Fig. 7).

To download the scheme from the server, proceed as follows:
1.	Enter server settings: address, port, login and user password for connection to the indicated 
server (Fig. 7, item 1). The “AutoGRAPH.WEB” option allows downloading files from AutoGRAPH 
Web Server.
2.	Click the “Connect” button to connect to the server for requesting available files (Fig. 7, item 2). 
After connection to the server the list of files available for the user will be downloaded. 
3.	Then select the “Schemas” tab, go to the list of available schemes, select the required schemes 
(Fig. 7, item 3) and press “Ok”. The selected schemes will be downloaded into the folder selected at 
the program installation step for storage of settings and data. Once the downloading is complete, 
the “Load files from server” menu will be closed automatically. 
4.	Open the downloaded scheme by selecting command Scheme > Open (Fig. 5).
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PROGRAM INTERFACE
THE MAIN COMPONENTS
The program interface may vary, depending on the scheme and desktop settings. The main 
interface elements of AutoGRAPH 5 PRO are considered below. 

1
2

6

5

7 8

3

4

Program header. Name, version and build, current scheme.

Menu bar. The main program commands and options are shown in each drop-down menu. 
Some commands may be enabled using key combinations. For details see “Menu bar” 
section. 

1

2

3

4

Fig. 8. Program interface.

Control bars. Control bars contain icons of the most frequently used program commands. 
When the cursor is placed over an icon, the icon function prompt appears. To view the bars, 
select Menu bar > View > Panels settings > Show control bars. Re-selection hides the menu 
bars.

The “Bug report” button. When the button is clicked, the “Bug reporter” menu appears. Using 
it, the AutoGRAPH 5 PRO program user can send a report about the bug to the program 
developers. 
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Language panel. When an icon is clicked on, a list of available languages appears, and the user 
can select the required language there. The experienced users may set up the translation 
language and add a new language from the special menu “Translator”. To enable the menu, 
run AutoGRAPH 5 PRO with the “translator” key (installed with the main software).

The “Event log” button. It calls the Event log where program stores entries about important 
program events, such as errors, warnings and program operation information. 

Status bar. It displays information about the current operations. If necessary, this bar can be 
hidden. For this purpose, de-select the “Show status bar” option in View > Panels settings. 

6

7

8

Desktop. It is a working area consisting of modules located in the specified order. The 
standard desktop is available in the program (Desktop 1), but the user can set up a 
customized desktop view arranging the modules conveniently. 

The active module is highlighted with a red box. When switching to another program the 
active module window is highlighted with a green box. The box highlighting is convenient 
when one module contains several windows – it enables monitoring the cursor. To restore 
the standard view of the current desktop, select View > Desktops > Restore.

5
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MENU BAR
Menu bar (Fig. 8, item 2) allows quick access to the main program functions. To access the desired 
menu, left-click on this menu and select the required command in the list which appears. 
The menu bar commands are detailed below.

THE “SCHEME” MENU

Fig. 9. The “Scheme” menu.

New – create a new scheme: empty or inherited 
(a copy of stored scheme). When a new scheme is 
created, the “Constructor” menu opens automatically. 
Using it, new modules can be added into the scheme. 

Open – open the scheme. The schemes available in 
this menu are stored in the folder \Schemes. The folder 
for scheme storing is set at the program installation 
stage.

Load from server – call the “Load files from server” menu which allows downloading user files from 
the server to a local disk. Enter the server parameters into the menu which appears, click the 
“Connect” button, and then select files to download. 

Save – save changes in the scheme. The scheme can also be saved by pressing the “Ctrl+S” key 
combination.

Save as... – save the scheme in a new file.

Delete files – delete files of the current scheme. The scheme files will be deleted once the scheme 
is closed. 

Exit – shut down the AutoGRAPH 5 PRO program. The program can also be shut down by pressing 
the “Alt+X” key combination. 

THE “VIEW” MENU

Fig. 10. The “View” menu.
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Desktops – in the drip-down menu the user can select a desktop from those available, create a new 
one, restore or delete the current desktop. The desktop determines location and appearance of 
modules, as well as the window width. For details about creation of a new desktop and editing the 
existing one see the “Desktop setup” section of this document. The “Desktops” menu options are 
unavailable, if the current scheme was not saved after changing. 

Skins – the menu allows selecting visual presentations. 

Panel settings – options in this menu allow setting up windows parameters (Fig. 11):

Show captions – allows showing/hiding module captions. To save desktop area, the module 
captions may be hidden. However, you must remember that modules (when the “Drag-and-
drop” function is enabled) can only be drag-and-dropped, if the module captions are displayed. 

Drag and drop panels – allows drag-and-drop panels on the desktop. To drag-and-drop a module 
window, left-click on the window caption and, holding the button pressed, move the window. 
Auto hiding on/off – allows automatic hiding of the module window if it is inactive. The window 
can be fixed or hidden by pressing button ,  (see Fig. 12).

Fig. 11. Panels settings

Fig. 12. The module window autohiding.
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Fig. 13. The “Setup” menu.

Options... – open the “Options” menu to set up global module parameters. The menu can 
alternatively be called by the “Ctrl+O” key combination.

Devices... – open the “Devices” menu to set up vehicle parameters. The menu can alternatively be 
called by the “Ctrl+D” key combination.

Geo-Fences... – open the “Geo-fences” menu to edit the list of geo-fences. The menu can alternatively 
be called by the “Ctrl+G” key combination.

Drivers – open “Drivers” menu to create, edit and set up the list of drivers. 

Implements – go to “Implements” menu to create and set up the tools list for the Field processing 
module.

Network settings – calls proxy server parameters setup menu. 

Tasks – open the user roles setup menu in the AutoGRAPH 5 PRO program. This menu is available 
if at least one of the setup servers supports the role-based safety system. 

Constructor – open the “Constructor” menu to create new and edit previously created schemes.

Hiding – it allows hiding windows. To hide a window, press the button . The module window 
can be displayed again by selecting the required module in the “Window” menu.

Large icons – sets large icons in window captions. 

Show control bars – allows displaying / hiding control bar. Control bar is located under Menu bar.

Drag control bars – allows drag-and-drop of control bar items. 

Show status bar – the option allows displaying / hiding the program status bar at the desktop 
bottom.

Full screen (Fig. 10) – allows expanding of the map over the whole screen. The map can alternatively 
be expanded over the whole screen by pressing the F11 key. For details about the full-screen view 
see the “Full-screen mode setup” section.

THE “SETUP” MENU
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THE “WINDOW” MENU
In the “Window” menu (Fig. 14) the user can open or display the required module. The modules 
marked with symbol  are started in the program. 

Fig. 14. The “Window” menu.

“HELP” MENU

Remote support – getting technical support by transferring the computer control to a specialist of 
TechnoKom LLC. 

To get the remote support, proceed as follows:
•	 Contact the specialist of TechnoKom LLC support service and agree on transfer of the computer 

control. 
•	 Select a system for remote support in the AutoGRAPH 5 PRO program (in which an execution 

error occurred) in the “Remote support” menu. Before selecting make sure the required system 
is installed in the computer.

•	 Then perform a connection according to prompts for the selected remote support system.

Fig. 15. The “Help” menu.
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About – information about the program: version, vendor’s contacts, copyright. 

Check for updates – check for availability of a new version of the AutoGRAPH 5 PRO on the server. If a 
newer program version is available on the server, then the user will be prompted to download and 
install that version. If the installed program is updated, then after the check a message will appear 
informing that the user uses the updated program version. 
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THE DESKTOP SETUP
The desktop determines the program client area view: arrangement and width of windows, 
window types (tabs, separate panels, etc.) and panels settings. 
The desktop setup commands are available in the “Desktops” section of the “View” menu. 

Fig. 16. Desktop setup.

The classic desktop – desktop of AutoGRAPH Dispatch Program, version 3.5.0 or higher. To quit the 
classic view, select Menu bar > View > Desktops and de-select the “Classic desktop” option. 

Current – the user can select and download the required desktop in this list. 

Restore – apply the latest stored configuration of the current desktop. The option allows restoring 
the desktop view if the parameters were changed. 

Save – save the desktop configuration. The program will prompt to enter the new desktop name. 
By default the program sets the current desktop name as the name of the new configuration 
automatically. The user can keep using the default name and overwrite the existing configuration 
or create a new desktop specifying a new name. 

Delete – delete the current desktop.

CHANGING THE DESKTOP CONFIGURATION
AutoGRAPH 5 PRO incorporates a special tool for a user to set up the desktop and select the panel 
layout (Fig. 17). 

Fig. 17. The Desktop constructor.

•	 To be able to move panels, you should 
enable window drag-and-drop and captions 
displaying. Go to Menu bar > View > Panels 
settings and make sure these options are 
active (Fig. 18). 

•	 To move a window, left-click on this window 
caption and holding down the button, drag 
the window. During dragging the constructor 
offers different window layout variants. To 
select the required layout, place the window 
over the required constructor icon and release 
the left mouse button. 
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Fig. 18. Panels settings.

•	 Also the desktop stores settings of windows and panels. The user can set up parameters of 
windows in the “Panel settings” menu located in the “View” menu of Menu bar (Fig. 18).

THE FULL-SCREEN MODE SETUP
This option allows expanding the program over the full screen. To switch to the full-screen mode, 
select Menu bar > View > Full screen and press F11 key or “Full screen” button in the bottom right 
corner of Map Viewer (Fig. 19).  

Fig. 19. The “Full screen” button in the Map Viewer.

To quit the full-screen mode, press F11 again or press Esc. 
The full-screen mode is available for both classic and user desktop views. 

THE FULL-SCREEN MODE OF THE CLASSIC DESKTOP
The panel set is fixed in the classic view – it includes Map Viewer, Diagram module and Viewer 
player. 
If two monitors are installed in the system, then the full-screen mode is expanded on the second 
monitor. It allows using both monitors simultaneously. 
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Fig. 20. Enable displaying the module in full-screen mode. 

THE FULL-SCREEN MODE OF THE USER DESKTOP
For user desktop view the full-screen mode panel list setup is available. The setup is performed 
in the “Constructor” menu (Menu bar > Tools > Constructor). In the “Constructor” menu select the 
required module in the list of the installed modules and go to the “Panels” tab (Fig. 20). Then to 
enable the full-screen module display, select the “Full screen” field for Panel 1.
In the full-screen mode the user can set up the user desktop view panels layout using the desktop 
constructor.
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COMMON SETTINGS
This section contains basic settings description of the AutoGRAPH 5 PRO. 

GENERAL INFORMATION
The basic settings of AutoGRAPH 5 PRO program modules are located in the “Options” menu. The 
menu can be called by selecting Menu bar > Tools > Options. The parameters list is located on the 
left side of this menu, and settings of these parameters are on the right side (Fig. 21).

Fig. 21. The “Options” menu. 

To display settings of the desired module, select the required module in the “Module” field (Fig. 22). 

Fig. 22. Search for settings over modules.
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To find the required setting, the menu search can also be used. To use it, enter the key word for 
search into the “Find” field (Fig. 23). 

Fig. 23. Search for settings.

Settings can be copied between similar sections in the “Options” menu. This feature can be used, 
for example, for copying settings of one module and applying the same settings to an identical 
module when several identical modules are installed in the scheme. To copy, select the desired 
setting, press the Ctrl+C key combination, then select a settings section into which the copied 
settings will be pasted, and press the Ctrl+V key combination. The settings common for modules 
will be automatically entered into the required fields during pasting. To paste individual module 
settings, place the cursor over the settings bar of the module accepting settings.

The “Autosaving scheme after apply options” option (Fig. 23) allows automatic saving of the scheme 
upon pressing the “Apply” or “OK” button in the “Options” menu.

THE TIME ZONE SETUP
To set up the time zone, select Menu bar > Tools > Devices. Then select the vehicle for setup, go to 
the “Properties – Time zone” section and select the “Time zone” field. The time zone settings will 
appear to the left of the module list (Fig. 24).
•	 To use the time zone set up in the system, select the “Use system time zone settings” option. 
•	 If it is necessary to use any settings different from the system ones, de-select the “Use system 

time zone settings” option and set up the time zone manually selecting the desired time zone in 
the “Time zone” field.

•	 When the time zone is changed, all program data will be time-shifted.
•	 The “Automatically adjust clock for Daylight Saving Time” option (available not for all time zones) 

allows automatic adjustment for daylight saving and standard time. 
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Fig. 24. Time zone setup.

THE SETUP OF IMAGE FOLDERS
The AutoGRAPH 5 PRO program uses images and icons for denoting different items such as geo-
fences, vehicles, stages, etc. in viewers. Images for each item type are stored in the separate folder 
and during the item setup the program requests images from the set up image folder. 
The image folders can be set up in the “Options” menu in the Folder settings section (Fig. 25). 
The user can set the path to different images of vehicles, drivers, icons of statuses, geo-fences, 
implements, etc. in this section. 
The “Add” button in each row allows adding images from any folder to the folder the path to which 
is indicated in this field. For this purpose, press the “Add” button and select the desired image (one 
or several) in the menu that appears. The selected image will be copied to the folder which was set 
by default for the selected image type. After that the copied images will be available for further 
use in the program.

Fig. 25. Setup of image folders. 
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USING THE ENVIRONMENT VARIABLE FOR SETTING THE PATH TO FOLDERS
The path to the desired folder can be set in the AutoGRAPH 5 PRO using an environment variable. 

Environment variable is a text variable of the operating system storing some information, for example, system 
settings data, path to the folder, etc.iNOTE

The use of the environment variable for setting up path to the folder allows specifying, for 
example, the path to the directory into which the AutoGRAPH 5 PRO program is installed, and 
use the environment variable into which a part of the path to directory is recorded instead of 
specifying the full path.
The environment variable must be added to the operating system. For example, to add a new 
environment variable in the MS Windows 7 operating system, go to the “System properties” 
menu, open the “Advanced” folder, and then click the “Environment variables” button (Fig. 26). The 
“Environment variables” menu will appear. Add a new variable and set its value. Fig. 27 illustrates a 
variable which stores the path to the directory in which the AutoGRAPH 5 PRO Dispatch Program 
is installed.

Fig. 26. System properties. Fig. 27. Environment variable.

Then AG variable may be used in the AutoGRAPH 5 PRO program to set up the path to different 
folders inside that directory. The example is shown in the Fig. 28.
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Fig. 28. Path to the folder using the environment variable.

THE PROXY SERVER SETUP
If the computer with the installed AutoGRAPH 5 PRO program is connected to the Internet via 
proxy server, then set up connection parameters for correct program operation. For this purpose, 
go to Menu bar > Tools > Network settings (Fig. 29). 

•	 If connection to the Internet is performed directly and not through the proxy server, then select 
the “No proxy, direct connection” option. In this case no further setup of network parameters is 
required. 

Fig. 29. Proxy server settings. 
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ADDRESS BASE SETUP
The AutoGRAPH 5 PRO program supports the use of .aga2 format address bases. Using the address 
base, the program computes the address closest to a coordinate point. If the address base is 
connected, then the point address instead of the coordinates will be displayed in the modules. 
To add the address base, go to the “Address base” section in the “Options” menu (Fig. 30).

•	 If the computer connects to the Internet via proxy server, and the AutoGRAPH 5 PRO program 
uses the proxy server system settings, then select the “Use system settings” option. In this case no 
further setup of network parameters is required. 

•	 If the computer is connected to the Internet via proxy server, and the AutoGRAPH 5 PRO 
program uses the proxy server settings different from the system ones, then select the “Use 
specified proxy” option and specify the proxy server settings – domain name or IP address of the 
server, connection port, login, password and connection type. In addition, the user may select 
the program resources which will use the proxy server: Data downloading, Schema upload/
download, Maps downloading, Messages and Auto updating. 

Fig. 30. Address base connection.

Some address bases of Russia may be added during the program installation. To add additional 
address bases, click the “Add address base” button on the “Address base” tab and select the required 
base. To delete an address base, highlight this base and click the “Delete address base” button. 
Then set up the “Threshold distance, m” parameter which sets the maximum address search zone 
in the address base in relation to the track point. If it is impossible to find the point address in the 
connected bases within the zone restricted by the search range, then coordinates of that point are 
displayed in the viewers instead of the address. 
If several address bases are added into the program, then the address search will be performed in 
all bases. In this case the address closest to the point will be considered to be the point address.
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Fig. 31. Address base converter call. 

In the “Converter” window go to the “Address base converter” tab. In the “Address base” field select 
the address base for conversion and click the “Convert” button (Fig. 32). The address base will be 
converted to .aga2 format.

Fig. 32. Address base converter. 

ADDRESS BASE CONVERSION 
Address base converter is integrated into Map Viewer. It is designed for conversion of other format 
address bases to the .aga2 format supported by the AutoGRAPH 5 PRO program. To start the 
Converter, go to the Map Viewer and click the “Converter” button on the top toolbar (Fig. 31). 
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DEVICE LIST
The list of devices is a list of vehicles with on-board AutoGRAPH controllers or equipped with a 
satellite monitoring system from a third party manufacturer. 

The data loaded into AutoGRAPH 5 PRO program are sorted into separate folders by serial numbers 
of controllers. To receive data from the device and to process received data in the program, add 
this device to the program, and then set data receipt and processing parameters. 

The list of devices is stored in Device selector (Fig. 33).
New devices are added to Device selector in the “Devices” menu. (Fig. 34). To go to the “Devices” 
menu select Menu bar > Tools > Devices. Also the “Devices” menu can be displayed by double-

Fig. 33. The Device selector. 

clicking the file with the desired vehicle data. In this case settings of this vehicle will be displayed 
in the menu at the opening. Similarly, the “Setup” command is executed in the shortcut menu of 
Device selector which is called by right-click on the vehicle.
The users can add new devices and new groups. The list may contain unlimited quantity of nested 
groups. By default only one group (Root) is added into the list. 
Below the procedure of adding new devices into the program and setup of these devices’ 
parameters is detailed. 
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Fig. 34. The “Devices” menu. 

ADDING NEW DEVICES
There are several ways to add new devices into the program:

•	 manual,
•	 import from an external file, and
•	 download the list of devices available for the user from the server.

Manually
This method is convenient, if it is necessary to add a small amount of new devices. In this case serial 
numbers of these devices should be known to the user in advance. 

To add a new device manually, proceed as follows:
•	 Select a new group into which the new device will be added in the “Devices” menu of the device 

list. 
•	 Then click the “Add” button or choose the “Add element” command in the shortcut menu. The 

button is located at the bottom of the list (Fig. 35, item 1).
•	 Enter a name of the new device (Fig. 35, item 2).
•	 Enter a serial number of the on-board controller in the “Serial No” field (Fig. 35, item 3). 

Fig. 35. Manual adding of a new device. 
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Import from an external file
The current version of the AutoGRAPH 5 PRO supports import of the device list from external files 
in .ini, .atg and .xlsx formats. The program supports import of tank settings, fuel consumption by 
fuel level in tanks, tare tables, some filters, meters, engines and sensors. 

To import the device list from an external file:
•	 Select a group into which the imported devices will be added. 

Fig. 36. Import from files.

•	 Select the “Import from files...” command in the 
shortcut menu of the “Add” button, then select a 
file for import (Fig. 36).

Import of available devices
To import available devices, at least one server for data reception must be set up in the scheme, 
and the user must be authorized in this server. Otherwise, “No available devices” message will 
appear at the attempt to request the list of available devices. 

To import the available devices:
•	 Select the “Import of accessible devices...” command in the shortcut menu of the “Add” button. 
•	 The program will download the list of devices available for the user from the server, and will 

prompt to select gauges from that list (Fig. 37). Select gauges and click “OK”. The selected gauges 
will be added to the Device selector.

Fig. 37. Import of accessible devices.
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After application of the settings the added devices will appear in the Device selector.
After adding of a new device, if such device inherits the parent group’s settings, then the program 
will automatically check for availability of the data from that device on the server and their 
availability to the user. If the data is available for the user, then they will be loaded into the program. 

If the new device’s data is stored on some other server, set up a new data source for that device 
after adding of the device. 
After application of the setting, the program will request data of the new device and offer 
authorization on the server from which the data is requested, unless the user is already authorized 
on that server. If there is data from device on the specified server, and the user has access to it, i.e. 
the new device is included into the list of devices of the user and it is not disconnected by billing, 
the data will be downloaded into the program.

For details about data source setup see the “Data source” section. 

THE DEVICE SELECTOR
The device selector stores the list of devices added into the scheme. An example of the Device 
selector is illustrated in Fig. 33. 
The vehicles are marked with individual icons in the Device selector. 

SEARCH IN LIST
The search in the device list is provided for convenience. The search menu is opened by clicking 
the  button in the right corner of the module.

DEVICE FLAGS
The user can additionally display different vehicle flags in the Device selector, for example, 
overspeed flag, park flag, etc.

Fig. 38. List of possible columns of the Device selector.

For this purpose, open the “Columns edit” 
menu in the Device selector by clicking  
button and set the required flags. 
For the parameter to be displayed in the 
“Columns edit” menu (Fig. 38), that parameter 
shall either be final (Fig. 39), or tabular with 
enabled “Using in total parameters lists” option 
(Fig. 40). 
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Fig. 39. Final parameter (The “Devices” menu, 
“Calculation – Calculation parameters” section).

Fig. 40. Tabular parameter (The “Devices” menu, 
“Calculation – Calculation parameters” section).

An example of displaying flags in the Device selector is provided in Fig. 41. 

THE OUTDATED DATA DISPLAY
If the vehicle data is outdated, then flags will be grayed in the Device selector (Fig. 41). If the vehicle 
parameter contains the current time in the expression for calculation, then that parameter is 
considered to be always updated and it is not grayed. The data is considered to be outdated if the 
last AutoGRAPH gauge entry is beyond the interval covered by online data. 
If the online data is generated based on the quantity of AutoGRAPH gauge entries, then the data 
actuality is not checked, and vehicle flags are not grayed in Device selector even when the data is 
outdated. 

Fig. 41. The device flags in the Device selector. 
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The data actuality time span is set up in the “Calculation – online calculation” section of the 
“Devices” menu. This setting can be set both individually for each vehicle, and for a vehicle group. 
For details see “Online and offline data” section of this Operation Manual. 

ONLINE DATA AVAILABILITY INDICATOR
Availability of data from vehicle in the Device selector is shown by online indicator (Fig. 30). The 
indicator can be shown or hidden in the “Options” menu in section Appearance – Vehicle columns 
and items showing, items order (Fig. 48), by disabling or enabling the “Hide online indicator” option. 

Fig. 42. The online indicator.

•	 If this data base contains any data from the 
vehicle, and these data is available for the 
current user, then the indicator is lit green 
(Fig. 30, item 1).  

•	 If the data from the vehicle is absent in the 
data base, or the data is unavailable for the 
user, then the indicator is lit red (Fig. 30, 
item 2). 

•	 The online indicator of the group is 
lit orange (Fig. 30, item 3), if the group 
contains any vehicles with data (green 
indicator) and without data (red indicator). 

THE TOTAL ROW
The Device selector total row indicates:
•	 If the cursor is placed over the vehicle, the serial number of the AutoGRAPH device installed 

on that vehicle and the license number of the vehicle if the license number is set in the vehicle 
settings, and the column with the license number is hidden (Fig. 43). The license number is set in 
Vehicle card.

•	 If the cursor is placed over a group, the quantity of groups and the quantity of devices from 
which data is present, as well as the total quantity of devices in a group (in parentheses) (Fig. 44). 

Fig. 43. The total row during vehicle selection. Fig. 44. The total row during vehicle group selection.
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To show the total row, right-click Device selector and select the “Show total row” command in the 
menu that appears. Re-selection of the command hides the total row. 

DEVICE GROUPING 
Devices in Device selector can be grouped based on parameters or properties, for example, 
based on groups which are geo-fences, sensor triggering, movement/stop, subdivisions, districts, 
categories, etc. 

Grouping setup procedure:
•	 Create a parameter for grouping. Grouping can be performed using parameters set up as final 

ones (Fig. 39), or as tabular, but with enabled “Using in total parameters lists” option (Fig. 40). 
•	 Find configuration file AutoGRAPHShell_x64.exe.config or AutoGRAPHShell_x86.exe.config  in the 

folder where the AutoGRAPH 5 PRO program is installed, depending on the software version in 
use. 

Fig. 45. Show / hide the Device selector total row.

The folder into which the AutoGRAPH 5 PRO is installed must be set up at the software installation stage. For 
details see the “Getting started” section (Software installation) of this document. iNOTE

•	 Add the following string into configuration file section <appSettings>: 
<add key=“grouping” value=“[Geofence1],Motion” />
Where value is the name of the parameter for grouping or parameter alias in brackets. If it is 
necessary to set several parameters, then their names in the string must be separated by commas. 
The grouping order will be as follows: first the vehicle list is grouped by the first parameter, then 
devices in each group are grouped by the second parameter. Example of the configuration file 
contents is illustrated below:
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<?xml version=“1.0”?>
<configuration>
  <uri>
    <idn enabled=“All” />
    <iriParsing enabled=“true” />
  </uri>
  <appSettings>
    <add key=“grouping” value=“Motion” />
    <add key=“url-information” value=“http://server.tkmonitoring.com/agnet.ashx” />
    <!--<add key=“update-url” value=“ag4://demo:demo@localhost:3226/ag/version.xml” />-->
    <add key=“update-url” value=“http://www.tk-chel.ru/download/AG5Setup/version.xml” />
    <add key=“update-delay” value=“15” />

•	 Save the configuration file.
•	 If the program was run during configuration file editing, then the software must be re-loaded.
•	 Go to the Device selector and enable the “Grouping” setting in the Dispatch Program (Fig. 46).
•	 Following the grouping settings change the grouping will be carried out correctly after online 

data receive. Whenever the program configuration changes (in the program itself ) or online data 
is received, the vehicle list is re-sorted by groups. 

Fig. 46. Vehicle list grouping.

•	 Sorting is carried out by grouping 
parameter values for each vehicle. If no 
grouping parameter is set in the vehicle 
settings, then the respective vehicle will 
be transferred to the “Unknown” group. If 
it is impossible to determine the value of 
the grouping parameter for the vehicle, 
for example, if the parameter for that 
vehicle is disabled, and its disabled state 
is not set up correctly for that vehicle, 
then the vehicle will also be placed to the 
“Unknown” group. 



AutoGRAPH 5 PRO • USER MANUAL40

TechnoKom © 2016

Fig. 47. Device selector view setup.

THE DEVICE LIST VIEW
By default, the names of devices and groups, and files received from those groups are displayed in 
the Device selector. In addition to the listed columns, some additional columns may be displayed 
in the Device selector. To set up the Device selector view, go to the settings section Appearance > 
Vehicle columns and items showing, items order in the “Options” menu (Fig. 47). 
In this menu the user can display or hide additional columns of Device selector, set up sorting by 
files, enable coloring Selector rows according to vehicle cursor color, etc.

•	 Hide root group in “Structure” view – the option hides upper level “Root group” object in the Device 
selector.

•	 Hide check boxes – the option disables displaying of check boxes in the module. The check boxes 
are used for selecting a vehicle, for example, during multi tack construction. By default this 
function is enabled.

•	 Hide “Number” column – the option disables displaying of the “Number” column designed for 
displaying the vehicle license number. If this option is disabled, then the vehicle license number 
(if specified) will be displayed in the Device selector total row when the respective vehicle is 
selected.

•	 Hide “Serial. No. (Serial Number)” column – the option disables displaying the column with serial 
number of AutoGRAPH device installed on the vehicle.

•	 Hide “Rcv. (Receiving)” column – the option disables displaying of “Receiving” column showing the 
state of new data reception. It is unavailable in the current version. 

•	 Hide “Msg. (Message)” column – the option disables displaying of the “Message” column designed 
for displaying the server messages transmitted by AutoGRAPH device, for example, AutoGRAPH-
NAVIGATOR device.

•	 Hide online indicator – the option disables displaying of online indicator designed for displaying 
actuality of the latest received data. For details see the paragraph “Online data availability 
indicator”. 
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VEHICLE IMAGE
In the AutoGRAPH 5 PRO program each device is assigned an icon which will be displayed in 
the Device selector and on the map near the vehicle cursor. To set up the vehicle icon, go to 
the “Devices” menu, then select a device for setup and go to the settings section Appearance > 
Background and foreground images (Fig. 48). In the right-hand menu select the vehicle image and 
set up its foreground image. 

Fig. 48. The main vehicle image setup.

•	 Hide inaccessible devices – the option hides the devices unavailable for the current user in the 
Device selector.

•	 Hide data sources – the option hides data sources in the Device selector – storage files and sources 
when the “Time span” view is selected. When the data sources are hidden, online data view is 
available. To view them, place the cursor onto the vehicle. 

•	 Disable “Files” view – the option disables “Files” view in the Device selector which is designed 
for distributing data over week storage files. When the option is enabled, the data view is only 
possible by the time span.

•	 Hide files in “Files” view older then – the option hides week storage files containing the data older 
than the specified age when the “Files” view is selected. If the “1 week” setting is selected, then 
data from the storage file for the current week (since the beginning of the current week, starting 
on Monday, at 00:00:00) will be shown when switching over to the “Files” view in the Device 
selector. The “2 weeks” setting allows showing files over the current and previous weeks, etc.

•	 Sort files in “Files” view top-down – a method of sorting storage files in the “Files” view in the Device 
selector.

•	 Coloring rows by cursor color – the option enables colouring rows with vehicle names in the Device 
selector according to the color of each vehicle’s cursor.  

The new data file is created on the server each Monday at 00:00:00 server time. Then the data received from 
AutoGRAPH device for 1 week from the file creation time are recorded into this file. Consequently, the week file 
may contain the vehicle data over the previous week if these data were sent to the server after creation of a 
new storage file.  

iNOTE
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The “Turn along track direction” option (Fig. 48) enables rotation of the vehicle image in the 
direction of movement. 
The selected icon will be displayed in the Device selector and in the map. 

For the main image to be displayed on the map, enable this option in the “Options” menu in section Appearance 
> Track and cursor on the “Image and cursor” tab. iNOTE

Fig. 49. The vehicle icon in the Device selector and on the map.

THE SETTINGS HERITAGE
Each device in the list of devices can have both individual settings and inherit the parent group’s 
settings. The device group settings are applied to all devices within that group except those 
devices for which individual settings are set. 
In the “Devices” menu, when a device or device group is selected, the settings heritage order is 
specified by means of an arrow – the arrow points to the group whose settings are inherited by the 
selected device or group. For example, in Fig. 50 the selected device inherits settings of the track 
colouring from its parent group.
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If individual settings are set for device or group, the arrow is absent, Fig. 51. 

Fig. 51. Individual settings are set for the device.

Fig. 50. The device inherits the group settings.
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DATA SOURCE. DATA BASE
The data can be loaded into the program either from a remote server (online data), or read from 
the device via USB (offline data). 

ONLINE DATA LOADING
To load the data from the server, an Internet connection at the user’s PC is necessary. To load data 
from the remote server, the program periodically or by user’s request acquired data from the 
specified servers. 
In addition, the AutoGRAPH 5 PRO program allows downloading data from a network storage. It 
allows to build within one organization such system in which one Dispatch Program acquires data 
from the server and saves them to a network folder, and other dispatcher workstations download 
data from that network folder. Such method of designing workplaces allows reducing the Internet 
resource costs significantly.

Remote server setup
To set up the remote server, go to Menu bar > Tools > Devices. Then select a group or a vehicle for 
the setup and go to section Servers > Server, password for device (Fig. 52). 

Fig. 52. Setup of server parameters. 

On the “Source” tab select the “Servers” option and set parameters of all servers from which the 
program will acquire data (Fig. 52):
•	 Domain name or IP address.
•	 Port. Port 2230 is automatically assigned to each new server address. The initial port for the new 

address can be set up in the “Options” menu, in section Servers > Downloading and saved accounts. 
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•	 Server software version. For version 3 of server software set the device password for access to that 
device’s data. The password needs to be set on the “Password” tab. The password is only displayed 
when selecting the device in the device list, as the gauge password is an individual parameter. 

•	 The “Use in WEB” option enables automatic data loading to the WEB version of the AutoGRAPH 
software during data loading to the AutoGRAPH 5 PRO program. To load data to the AutoGRAPH.
WEB a respective scheme with the list of required vehicles must be loaded to the server for WEB 
interface. 

•	 The “Require information about trips” option – if this option is enabled, then the Dispatch Program 
will load information about placement and removal of a vehicle to/from the trip along with the 
data. Information about trips is stored in .route format file which is created on the server, in the 
Data folder of the gauge, when the gauge is placed for a trip. 

Upon setting all server parameters, save settings by clicking the “OK” button. Upon saving the 
settings and quitting the “Devices” menu the program prompts to enter the password for access 
to data on the specified server. If several servers are specified for data request in the settings, then 
the program will prompt to enter login and password for each server. 

Network folder setup
If the Dispatch Program loads data from the network storage, set the path to that storage. For this 
purpose, go to Menu bar > Tools > Devices, and then to section Servers > Server, password for device 
(Fig. 53). 
On the “Source” tab select the “Data-folder” and set the path to the network storage where the 
device data is stored. 

Fig. 53. Setup of network folder. 

Upon setting the network storage parameters, save settings by clicking “OK” button. Authorization 
is not required during downloading data from a network folder. 
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Non-sequential data reception
AutoGRAPH 5 PRO support the feature of sorting data from navigation terminals of third-party 
manufacturers transmitting data not in chronological order.

•	 For automatic data sorting at a reception enable the “Correct data with non-sequential date/
times” option – go to section Servers > Data sorting and enable option (Fig. 54). 

•	 If there are any non-sequential data in the AutoGRAPH 5 PRO program data base which have not 
been sorted chronologically at the reception, then the user may sort these data manually. For 
this purpose, go to the “Force resort data” menu which is called by clicking the “Sorting...” button. 
Select data in this menu and click the “Start” button to start the sorting.

Fig. 54. Non-sequential data sorting.

Receive online data
The online data is received using the Online Device Provider module (Fig. 55). 
Every Monday on 00:00:00 a.m. server time a file with .sbin extension containing device entries is 
created on the server. 
With a certain time span the Online Device Provider manually or automatically requests the data 
from the server and loads them into the Data folder of the AutoGRAPH 5 PRO program. 
The data is accessed using login and password for AutoGRAPH 4.0 or higher server version or using 
key files for AutoGRAPH 3.0 server version. 
The progress of data loading from each server and network storages to the AutoGRAPH 5 PRO 
is displayed on individual panels or tabs (Fig. 55, item 1): information about the total amount of 
received data, the last file reception date and the amount of data received over the latest time 
span. Double-clicking on the row of the loaded data list places the Device selector cursor over the 
caption of the respective vehicle for viewing online data. 
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Fig. 55. Online device provider.

The total row (at the bottom of the table) displays the total amount of loaded data and the quantity 
of polled controllers. The data loading log is displayed in the state progress window (Fig. 55, item 2). 
The “Get data” button allows manual data request. 
The “Stop” button allows interrupting the data reception. 

Also the data may be requested using “Receive online data” button on the control bar. Commands 
in the shortcut menu allow receiving online data of a device group selected in the Device selector, 
one device or all devices added into the scheme. 

To request data from an individual vehicle or vehicle group, go to the Device selector, select 
the required vehicle or vehicle group, then right-click and select the following in the menu that 
appears:
•	 The “Request online data for device ” command, if the vehicle is selected (Fig. 56).
•	 The “Request online data for group” command, if the vehicle group is selected (Fig. 57). 
The selected vehicle or group data loading progress will be displayed in the Online device provider 
state window (Fig. 55, item 2).
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Data reception parameters
To set up the data reception parameters and set the automatic downloading time span, go to the 
“Options” menu to section Servers > Downloading and saved accounts (Fig. 58). 

In the “Common settings” box set up the following data reception parameters:

•	 Request period – time span with which online device provider will request data from the server. 
The requests may be sent either manually (by clicking the “Get data” button) or automatically, if 
the request period is set.

•	 Do not download files older than,weeks – disables loading of files which are older than specified 
time from the server. The time must be specified in weeks. 

Fig. 56. Request device online data. Fig. 57. Request device group online data.

Fig. 58. Data downloading parameters.
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•	 Request attempts number – the maximum quantity of attempts of connection to the server after 
which, in case of a failure to connect to the server, the data loading is postponed till the next 
time span. 

•	 Initial port for new host end point – number of the port which will be automatically specified when 
a new server for data request is added.

•	 Parallel threads for downloading – quantity of simultaneous data downloading streams. This 
parameter is used for downloading acceleration. For 2G and 3G networks it is recommended to 
use 1 or 2 parallel streams, for faster networks – 4 to 8 . 

•	 Batch size – the quantity of gauges polled simultaneously. 

In addition, the user can delete any previously saved server access passwords in this menu. When 
the passwords are saved, the program will not request for them at each scheme start. 
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OFFLINE DATA LOADING
The data from on-board AutoGRAPH controller / AutoGRAPH device can be read to the AutoGRAPH 
5 PRO Dispatch Program via USB. 
Data reading from AutoGRAPH controllers / AutoGRAPH devices via USB is provided by the “Offline 
device provider” module. When the USB controller is connected to PC port, if automatic data 
reading is enabled, the program will read data from the connected device to the data base to 
which the Offline device provider is connected. 

To read data from AutoGRAPH controller / AutoGRAPH device, proceed as follows:
•	 Connect the device to PC on which the AutoGRAPH 5 PRO program is running using a USB cable. 

Upon connecting the serial number and the device firmware version (Fig. 59, item 1) will be read. 
•	 If the automatic data reading is enabled in the settings of the Offline device provider, then the 

data will be read immediately after connection of the device to USB. If the data was not read 
automatically, then click the “Start” button. 

•	 The data reading progress is displayed in the progress window (Fig. 59, item 2), the current 
operation and the progress of such operation are displayed in the “Operation” string. 

•	 The read data will be loaded into the data base and will appear in the Device selector, if a device 
with the respective serial number is added into Device selector. If there is no required device in 
the Device selector, add a new device with serial number corresponding to serial number of the 
connected gauge. After adding the new device any read data will be associated with the new 
device based on its serial number and will be accessible for processing. 

To interrupt the current operation performed by the Offline device provider, click the “Stop” button 
(Fig. 59). To delete data from the connected device, click the “Delete entries” button.

To read the data from the on-board AutoGRAPH controllers / AutoGRAPH devices, the device drivers 
must be installed in the system. For more details about necessary drivers see User Manual for the 
specific device. iNOTE

Fig. 59. Offline device provider.

2

1
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In this menu the user can set up the following parameters:
•	 Hide panel when device is disconnected – enable hiding the module window if there are no devices 

(AutoGRAPH controllers / AutoGRAPH devices) connected via USB. 
•	 Start reading immediately after USB connection – automatically read the data when AutoGRAPH 

controller / AutoGRAPH device is connected to USB. By default the program reads data after 
clicking the “Start” button in the Offline device provider. 

•	 Do not create copies of previous file after reading – do not create a new file with week data when the 
data is read from the controller, if such file exists already – for example, if it was created during 
previous device connection and data reading.

•	 Method of entry deletion after reading:
Do not delete (by default) – do not delete entries from the connected controller after reading.
Offer to delete – after reading entries prompt the user to delete them. 
Delete without offer – after reading entries delete them from the controller without asking 
confirmation. 

Fig. 60. Offline data downloading parameters. 

Offline data reading parameters
Offline data reading parameters can be set up in the section Behavior > Operations when USB-
connected of the “Options” menu (Fig. 60). 

DATA BASE
The data received from the server and read via USB is stored in the Data base. By default the data 
is stored in the folder Users\...\AppData\Roaming\AutoGRAPH Shell\Data on the system drive. If 
required, the user can select some other folder. For this purpose, go to the section Folder settings 
> Folder for data in the “Options” menu, and set up the data directory on the “Parameters” tab (Fig. 
61).
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Fig. 61. Data folder. 

For convenience the user may set up data sorting in the Data base. For this purpose, go to the 
settings section Operations > Moving and deleting data files in the “Options” menu and set up the 
Data base parameters (Fig. 62). 

•	 Delete files older than – allows deleting from the Data base files older than the specified time. 
Deletion of old files is performed at each start of the AutoGRAPH 5 PRO. After setup of the 
deletion time span the user can delete old files at once, without program reloading, clicking the 
“Delete old files now” button.

•	 Move files from Data-folder to the devices subfolders – the option allows automatic transfer of data 
files to subdirectories of respective gauges.  When the data is downloaded from the server via 
USB, a separate folder is created in the \Data folder for each device where that device’s data is 
stored. Sorting is performed by serial numbers of devices. Each folder’s name corresponds to 
serial number of the device the data of which are stored in this folder. 

Fig. 62. Data base parameters.
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ONLINE AND OFFLINE DATA
Vehicle offline data is all data received from the on-board controller installed on that vehicle and 
stored in the data base. Offline data allow reproducing the vehicle movement history, and restore 
the vehicle parameters state at any time of interest. To view the offline data, place the cursor over 
the file with data or data source. The vehicle offline track – history of the vehicle movement over 
the time interval of interest is formed based on the offline data. 

Online data is the latest data of the vehicle: the latest known location coordinates, the latest known 
states of the vehicle parameters, etc. 
The volume of the vehicle data related to the online data is limited. To set up the online data view 
interval, go to the section Calculation > Online calculation in the “Devices” menu. 

Fig. 63. Data folder. 

•	 If the “Fixed period to the present time, h” setting is selected, then online data is gathered for the 
interval covered by specified fixed time span (in hours) till current time. If the latest data time falls 
within the interval covered by online data, then the data is considered to be updated. 

•	 If the “From time of the present day” setting is selected, then online data is formed for the current 
day, beginning with the specified time. The time is set in 24-hour format. If the latest data time 
falls within the interval covered by online data, then the data is considered to be updated. 

•	 If the “By entries number” setting is selected, then online data is formed from the 
specified quantity of entries of on-line AutoGRAPH controller / AutoGRAPH device. 
In case of such setting the vehicle online data is considered to be always updated.  
The number of controller entries for calculation of online parameters can be limited in the “Entries 
number for pre-detect last parameters” section. 
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Old 12-bit devices (.bin, ~240 entries per hour) are devices with data stored in .bin files. Such devices 
include all AutoGRAPH-GSM series controllers up to serial No. 52499 inclusive and AutoGRAPH-
WiFi series up to serial No. 91099 (firmware version 1.0). Such controllers generate about 240 
entries per hour on average. 
New 16-bit devices (.sbin, ~300 entries per hour) are devices with data stored in .sbin files. Such 
devices include AutoGRAPH-GSM controllers, beginning with serial No. 52500 (firmware version 
7.0 or higher), AutoGRAPH-WiFi series, beginning with serial No. 91100 (firmware version 2.0 or 
higher), as well as all personal controllers AutoGRAPH-Mobile and search systems AutoGRAPH-
ST. 16-bit devices (except AutoGRAPH-ST) generate about 300 entries per hour on average. 

An online track can be formed from online data, if the online track formation condition is fulfilled. 
For details see the “Vehicle track and location” section.

The calculated online data is displayed in the Device selector and in the Entries list. In the current 
software version the online data generated by number of entries is displayed in the Entries list. 
The vehicle data over the time span covered by the online data is displayed in the Device selector, 
in the row with the vehicle header.

Fig. 64. Online data in Device selector.

The desired columns in the Device selector can be shown and the undesired can be hidden in the 
“Columns edit” menu which is opened by clicking  button in the right corner of the module 
window. 

To calculate the parameter value for the time span covered by the online data, this parameter 
shall be included into the list of final parameters (Fig. 65). If the parameter is included into tabular 
parameters, set up the output of the final value of the parameter in the list of final parameters (Fig. 
66). 
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Fig. 65. Parameter online value calculation. Fig. 66. Tabular parameter online value calculation. 
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VEHICLE TRACK AND LOCATION
A track is a vehicle motion path built on the basis of coordinate entries of the on-board computer. 
There are two types of track – online track and offline track. 

Fig. 67. Vehicle Track.

ONLINE TRACK
Online track is a vehicle track built by online data. To build an online track, the online track 
generation condition must be set in the program. If the online track generation condition is not 
set, the online track will not be built. 

ONLINE TRACK GENERATION
To set up the online track generation parameters, go to the settings section Appearance > Track 
colouring in the “Devices” menu, then select the “Online track” tab (Fig. 68). 
Set up the online track generation condition on this tab in the “Condition” field. The set condition is 
checked from the latest (the most actual) entry and over the whole interval covered by online data. 
The latest coordinate entry made by the gauge will always be the last online track point, and the 
coordinate entry following the first fulfillment of the condition (for checking from the track end) 
will be the first online track point. 
If the set condition is not fulfilled on the segment covered by online data, the online track will not 
be built. 
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Fig. 68. Online track generation condition.

ONLINE TRACK VIEW
To view the online track, place the Device selector cursor over the device header. An example of 
the online track is shown in Fig. 69. 
The latest known location of other vehicles is also displayed on the map along with the online 
track; depending on the settings, the current vehicle group, all vehicles, etc. can be displayed.

Fig. 69. Display online track.

If the online track fails to be generated during the device selection, it is possible that the online 
track condition has not been set, or the online track generation condition is not fulfilled for the 
selected device. 
Left click on the online track displays a pop-up window with information about the nearest track 
point. Vehicle cursor movement (by double-click1) is unavailable for online track. 
Vehicle cursor on online track shows the latest known vehicle location point. 

1 Double click is a clicking the left mouse button twice without any long pause between clicks.
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Fig. 70. Display week track.

If the data is sorted by files 
in the Device selector, select 
a file for viewing (Fig. 70). 
In this case the track will 
be generated based on the 
week data.

OFFLINE TRACK
Offline track is the main vehicle track built based on the offline vehicle data. The offline track is 
generated based on all entries of the on-board controller. 

OFFLINE TRACK VIEW
To view the vehicle offline track:

1.	Select this vehicle’s data in the Device selector (a week data file or the data over the time span 
of interest).

If the data sorting in the 
Device selector is performed 
by time span, select data 
from the required source 
(USB, GSM, etc.), then set up 
the time span for which the 
track will be built in the Time 
span selector (Fig. 71).  

Fig. 71. Display track for the time span.

2.	Then, if the data is broken down into trips in the Trips selector, select a trip for viewing. The trips 
selector breaks down the data which is selected in the Device selector (week data or data over a 
time span).
3.	After that the selected vehicle’s track will be built on the map over the selected time span or 
from the selected storage file. If the breakdown into trips is performed, then the vehicle track over 
the selected trip will be shown on the map. If there is no data for track generation over the selected 
time span or in the selected file, then the track will not be built. 
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TRACK ELEMENTS
Different elements such as movement direction, track points, stages, etc. can be displayed on the 
track.

Fig. 72. Track elements.

•	 The track starting point is highlighted with a special icon on the track (Fig. 72, item 1). 
•	 If required, the points corresponding to coordinate entries of the on-board controller can be 

shown on the track (Fig. 72, item 2). 

Fig. 73. Track point.

To show track points, click the “Show track 
points” button which is located on the 
bottom toolbar of Map Viewer (Fig. 72, item 5). 
Left click on a track point displays a pop-up 
window with information about the selected 
point (Fig. 73). 

•	 The vehicle movement direction is shown by the arrows on the track (Fig. 72, item 3). The arrows 
may be hidden if required. To show or hide direction, click the “Show track direction” button 
which is located on the bottom toolbar of Map Viewer (Fig. 72, item 5).

•	 The vehicle position at the selected time, including the current vehicle position is displayed 
using Vehicle Cursor (Fig. 72, item 4). Vehicle cursor is described in more detail in the following 
paragraphs. 

•	 The vehicle track may be hidden. To hide it, click the “Hide track” button on the bottom toolbar of 
Map Viewer (Fig. 72, item 5). If the track is hidden, then upon the data selection the latest known 
location of the vehicle over the selected time span is displayed.
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Fig. 74. Dotted line on the track. 

•	 If long time has passed between the neighboring track points, then the track in the map may 
be replaced with a dotted line connecting those points. The dotted line appearing on the track 
may mean absence of coordinates or poor reception condition and, consequently, unreliable 
coordinates. An example of the dotted line connecting the track points is given in Fig. 74. 

To set up the maximum permissible time between the neighboring coordinate entries, go to 
the “Devices” menu, to section Appearance > Track colouring, to the “Main track” tab(Fig. 75). The 
parameter is set up in the “Maximum duration between coordinates, min.” field. The parameter 
value must be set in minutes, the minimum value is 5 minutes, the maximum value is 30 minutes. 
The parameter is set up with the track colouring and may be set both for a device group, and for 
an individual device. 

Fig. 75. Setup of the maximum duration between coordinates. 
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When using vector maps, map matching to roads may be set up for a more accurate track building. 
To set up this option, go to the “Devices” menu, select a device or group for setup, then go to the 
settings section Calculation > Filtration and correction and select the “Correction” tab (Fig. 76). On 
this tab enable the Map matching to vector map roads, and set the maximum distance from the 
track to the road to which the track may be matched. The distance shall be specified in meters.

Fig. 76. Setup of track matching to roads. 

TRACK APPEARANCE
To set up the track appearance, go to the settings section Appearance > Track and cursor in the 
“Options” menu, then select the “Track” tab (Fig. 77). 

Fig. 77. Setup of external track view.
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It is recommended to set up the following track parameters on this tab: 
•	 Match scale to track – this option allows automatic change of the map scale to wholly accommodate 

the selected track in the map working area.
•	 Draw track outline – allows drawing the track outline. It is also recommended to set up the track 

outline thickness for this option. 
•	 Track thickness (pixels) – select the vehicle track thickness. The settings is specified in pixels.

TRACK COLOURING
The track colouring may vary depending on the state of vehicle parameters. Track may be single-
colored or multi-colored. 
To set up the track colouring parameters, go to the “Devices” menu, select a device or device group 
for setup, then go to the settings section Appearance > Track colouring (Fig. 78). 
Then to set up the online track colouring go to the “Online track” tab, to set up the offline track go 
to the “Main track” tab. 
The online and offline track colouring settings are identical. Therefore, the track colouring setup 
will be considered by the example of the offline track (main). 
To set up the main track colouring, set the following parameters:

Fig. 78. Offline track colouring.

1.	Select the track color definition criterion (the “Color defined by” option). The track color may be 
determined by:
•	 Parameters – the track color will depend on the state of several vehicle parameters. For this setup, 

set the list of parameters determining the track colouring, values of these parameters and track 
colors corresponding to the set values of these parameters in the table. The required parameters 
must be added to the device data handler in advance. 
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•	 In Editor of CP and polygons select “Track – Save” command, then select format of the file into 
which the track will be exported (Fig. 80). The track will be saved to file of the selected format. 
When exporting track to .kml format the movement height data is also exported.

Fig. 79. Open the Editor of CP and polygons.

Fig. 80. Track export.

•	 Switch statuses – the track color will be determined by the switch statuses. For this setting select 
the switch determining the track color in the left field. The track colouring parameters are fully 
determined by switch settings. 

•	 One parameter – the track color will be determined by the status of one vehicle parameter. In the 
left field select the parameter which will determine the track color, then in the table set the list of 
values for this parameter and track colors corresponding to these values.

2.	Set up the track color without colouring change (the “Default color” option). 
The preview of the track with the specified settings is displayed at the bottom of the table (Fig. 78).

To set up the online track colouring go to the “Online track” tab. 

The main track colouring is applied to the online track by default. To set the online track colouring 
different from the main track colouring, de-select the “Use the main track colouring” option, then 
set up the online track colouring. 

TRACK EXPORT 
The AutoGRAPH 5 PRO program allows exporting the vehicle track to .kml and .plt files for data 
exchange with the third-part manufacturer’s software (Google Earth, OziExplorer).  
To export track for the time span of interest to one of the supported export formats:
•	 Display that track on the map.
•	 Call Editor of check points and polygons by clicking Editor of check points and polygons on the 

upper toolbar of Map Viewer (Fig. 79).
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VIEWING THE LATEST KNOWN COORDINATES
The AutoGRAPH 5 PRO program allows displaying the latest known coordinates of all or selected 
vehicles on the map. To view the latest known vehicle coordinates, place the Device selector cursor 
over the vehicle or vehicle group header. 
The display mode depends on the settings specified in Map Viewer. In Map Viewer open the 
“Vehicle display mode” menu on the bottom toolbar, then select the desired vehicle display mode 
(Fig. 82). 

Current group only – if Device selector cursor is placed over the device, then in this mode the latest 
known location of all devices included into the selected device’s group is selected on the map. If 
the selected device is in the root group, then all devices of the root group will be displayed on the 
map. If the Device selector cursor is placed over the group, then all devices of that group will be 
displayed on the map.
Current group and insides – if the Device selector cursor is placed over the device, then in this mode 
the latest known location of all devices included into the selected device’s group and all devices of 
nested groups is selected on the map. If the selected device is in the root group, then all device list 
will be displayed on the map. If the Device selector cursor is placed over the group, then all devices 
of that group and all devices of nested groups will be displayed on the map.
All vehicles – all devices from the device list will be displayed in this mode.

•	 Commands in the “Save and open” section allow exporting track to .kml and .plt formats and 
opening it after saving (Fig. 81). To open the track, the respective software must be installed in 
the computer: for opening .kml format – the Google Earth program, for opening .plt format – the 
OziExplorer program. 

Fig. 81. Save and open track.

Fig. 82. All vehicles display mode. 
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Fig. 83. Vehicle display mode does not include this vehicle.

All check vehicles – the latest known location of vehicles selected in the Device selector is displayed 
on the map in this mode. To select a vehicle in Device selector, check boxes shall be displayed. 
In this mode, if the Device selector cursor is placed over a vehicle which is not checked, then the 
message “Vehicle display mode does not include the vehicle” will appear (Fig. 83).

The vehicle location is displayed by a special vehicle cursor and image on the map, if the image is 
selected in the device settings, and its display is enabled. 
As new data is received, the device locations will be updated according to the received data, 
showing the updated vehicle positions to the dispatcher. 

In the “Options” menu the user can set up all vehicles’ display mode parameters. For this purpose, 
go to the settings section Appearance > Track and cursor in the “Options” menu and select the 
“Vehicle cursors” tab (Fig. 84). 

Fig. 84. All vehicles display mode parameters.



AutoGRAPH 5 PRO • USER MANUAL66

TechnoKom © 2016

It is recommended to select the necessary parameters for viewing all vehicles in the “Others” 
section. The settings described below are only related to offline and online track display modes. 
•	 The “Show vehicle status” option allows displaying vehicle statuses including statuses received 

from AutoGRAPH-NAVIGATOR devices on the map near the vehicle icon (Fig. 85, item 1).
•	 The “Show direction on vehicle if the cursor is out of screen” option allows displaying the approximate 

vehicle position as an arrow on the map, if vehicle cursor is beyond the map working area (Fig. 
85, item 2). Double-clicking1 the arrow centers the map to the Vehicle cursor to which the arrow 
points. 

•	 The “Adjust the scale by the vehicle group” option allows automatic matching of the map scale 
during viewing all vehicles so that all vehicles reside within the map working area. 

•	 The “Show moving vehicles only which data no older than” option disables displaying on the map the 
vehicles which do not move according to online data and the latest data of which are older than 
the set interval. 

1 Double click is a clicking the left mouse button twice without any long pause between clicks.

Fig. 85. Display all vehicles.
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OPERATIVE GROUP
Operative group is a group of vehicles which is always displayed in all vehicles display mode, 
irrespective of the group which is selected for viewing. 

To display operative groups, call the “Vehicle display mode” menu located on the bottom toolbar 
of Map Viewer, then check the box opposite the “Show operation groups” option (Fig. 86).

Fig. 86. Show operative groups. 

To set the vehicle group as an operative one, go to the “Devices” menu, select the desired device 
group, then go to the settings section Properties > Operative group. Then check the “Operative 
group” option on the “Parameters” tab (Fig. 87). 

Fig. 87. Setup of the “Operative group” property.

The “Operative group” property allows monitoring movements of the most important objects, 
continuously displaying their current positions on the map. 
Fig. 88 illustrates an example of displaying all vehicles on the map, including operative groups. 
Each vehicle is highlighted with the cursor and (if specified in the settings) with the vehicle icon. 
In addition, statuses of different device operating parameters may be displayed near the vehicle 
cursor.  
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Fig. 88. Display all vehicles and operative groups.

Fig. 89. Last moving trail.

In the AutoGRAPH 5 PRO program a feature of constructing the vehicle moving trail based on 
the latest received data is provided. The trail shows an approximate vehicle motion path over the 
several latest seconds in all vehicles display mode (Fig. 89).  
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Fig. 91. Setup of last moving trail.

To set up the trail construction parameters, go to the settings section Appearance > Track and 
cursor in the “Options” menu and select the “Vehicle cursors” tab (Fig. 91). 
Select trail type and length on this tab. 

STATIONARY OBJECTS
Stationary objects are non-moving monitoring objects having fixed location coordinates. Particular 
coordinates are set for such objects, and when the new data is received, the program matches the 
received coordinates to stationary ones. It enables filtering random deviations of coordinates. 

An example of a stationary object is shown 
in Fig. 90. 

Fig. 90. Stationary object.

To set up an object as a stationary one and set fixed coordinates:
•	 Go to the “Devices” menu and select the desired device for setup.
•	 Then go to the settings section Properties > Stationary object (Fig. 92).
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Fig. 92. Setup of stationary object coordinates.

•	 To set up an object as a stationary one, check the box opposite the “Stationary coordinates” 
option in the right menu and set the object coordinates (Fig. 92). 

For such objects the coordinates received from the server will be replaced with stationary ones, 
haulage will be considered to be equal to zero, and the status will be considered to be a stop. Fig. 
93 illustrates Entries list, including coordinate entries, for Stationary object. 

LAST MOVING TRAIL

Fig. 93. Stationary object entries.
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VEHICLE CURSOR
Vehicle cursor is a special icon (Fig. 94, item 1), which shows:
•	 the current vehicle position during online data viewing,
•	 vehicle position at selected time (for example, during track playback),
•	 vehicle position at the time of beginning (or end, depending on settings) of the stage, trip, etc,
•	 vehicle movement direction, and
•	 position of all vehicles of the selected group by their latest known coordinates.

Fig. 94. Vehicle cursor and image.

CURSOR VIEW
To set up the cursor parameters, go to the settings section Appearance > Track and cursor in the 
“Options” menu and select the “Vehicle cursors” tab (Fig. 95).
•	 On this tab set up the cursor size and the text under the cursor (in the “Dimensions” box). By 

default the vehicle name or serial No. (if the name was not set) is displayed under the cursor. 
•	 The selected vehicle icon is highlighted with a bounding box. The bounding box color and view 

can be selected in the “Selected vehicle cursor” settings box(Fig. 95). 

Fig. 95. Settings of 
vehicle cursors.
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In addition to vehicle cursor the vehicle position can be designated with an image specified for 
that vehicle. If necessary, vehicle cursor or vehicle image can be hidden. 
To set up the general cursor parameters and vehicle image, go to the settings section Appearance 
> Track and cursor in the “Options” menu and select the “Image and cursor” tab (Fig. 96). 
The user can select a method for vehicle designation on the map:

Fig. 96. Vehicle cursor and image.

•	 Image and cursor – allows designating the vehicle using a cursor and vehicle image.
•	 Only cursor – allows showing only vehicle cursor.
•	 Only image – allows showing only vehicle image. 

Also the user can select relative positions of cursor and image in the drop-down list:
•	 Image under the cursor (image and cursor are superimposed on one another in such a way that 

the image is on the lower layer, cursor is on the upper layer),
•	 Image to the left of the cursor,
•	 Image on top of the cursor,
•	 Image to the right of the cursor, and
•	 Image below the cursor.

The “Enable image rotation” option enables rotation of the vehicle image in direction of movement. 
If this option is disabled, then to accelerate the data processing any rotations of the images are 
disabled, even if the vehicle image rotation is enabled in the device settings (in the “Devices” 
menu). 
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VEHICLE CURSOR COLOURING

The vehicle cursor colouring is provided in the AutoGRAPH 5 PRO program based on different 
criteria. The cursor colouring is only displayed in offline track display mode. 
To set up the vehicle cursor colouring, go to section Appearance > Cursor colouring in the “Devices” 
menu (Fig. 97). The cursor colouring can be set both for a vehicle group and individually for each 
vehicle.
To set up the cursor colouring, set the following parameters:

Fig. 97. Setup of cursor colouring. 

1.	Select the cursor color definition criterion (the “Color defined by” option). The cursor color may 
be determined by:
•	 Parameters – the cursor color will depend on the state of several vehicle parameters. For this 

setup, set the list of parameters determining the cursor colouring, values of these parameters 
and cursor colors corresponding to the set values of these parameters in the table. The required 
parameters must be added to the device data handler in advance. 

•	 Switch statuses – the cursor color will be determined by the switch statuses. For this setting select 
the switch determining the cursor color in the left field. The cursor colouring parameters are fully 
determined by switch settings. 

•	 One parameter – the cursor color will be determined by the status of one vehicle parameter. In the 
left field select the parameter which will determine the cursor color, then in the table set the list 
of values for this parameter and cursor colors corresponding to these values.

2.	Set up the cursor color without colouring change (the “Default color” option). 
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TRIPS AND TRIP DATA
This section of User Manual contains an instruction for setup of splitters, splitting of a track into 
trips, displaying trip data and setup of trip parameters.
The AutoGRAPH 5 PRO program allows splitting a track and data into trips based on different 
criteria and calculate the trip data. 

TRIP SPLITTERS
This section describes the procedure of splitter creation and splitter setup.
To create splitters, go to the “Devices” menu; for this purpose, select Menu bar > Tools > Devices. 
In the “Devices” menu select a device or a group of devices for which it is necessary to set up 
splitting into trips, then go to the settings section “Trip splitters” (Fig. 98). In this menu only one tab 
“Splitters” is available. The tab consists of two menus: In the top menu set the trip splitters, and in 
the bottom menu specify the splitter settings. 

Fig. 98. Setup of splitters.

In the AutoGRAPH 5 PRO program several independent groups of splitters can be created (Fig. 98, 
item 1). Each group also can contain several different splitters. Inside the group splitting into trips 
is performed as follows. All vehicle’s track over the selected time span is split into trips by the first 
splitter (the first one on the splitter list), then trips generated based on the first splitter are split 
based on the second splitter’s settings, etc.
By default one splitter group (Splitters 1) is created in the vehicle settings. To create a new splitter 
group, click  button next to splitter groups tab, then go to this group’s tab to add splitters to 
this group. 
Double click on the tab header enables editing the tab description – splitter group name. The 
group name is displayed in Trips selector in the splitter selection list. 
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To delete a splitter group, go to this group’s tab, then click button   (Fig. 98, item 2). 

To add a new splitter:
•	 Select a splitter group in the top menu, then set the splitter name in the new string in the 

“Description” field, for example, “Shift” (Fig. 98, item 3).
•	 Then select the desired splitter type in the “Type” field. When the type is selected, the program 

prompts to set the default splitter settings. The user can accept the default setting or cancel it 
and set the settings manually. The following types are available in this program version:
By date and time – a new trip will start and be completed on the specified date and at the specified 
time. 
By day of year – a new trip will start and be completed in the specified month, day and time.
By day of month – a new trip will start and be completed on a particular day of the month.
By day of week – the new trip will start and be completed on a particular day of the week.
By time of day – a new trip will start and be completed at a particular time of day.
By condition – the trip continue until the set condition is fulfilled. 
By branch “No”–>”Yes” – each new trip will start once the set condition fulfilled. The current trip 
will be completed automatically once the next trip begins.
By status change – a new trip will start each time the parameter status changes, for example, by 
change of status of the switch displaying the current driver.
By geo-fences – a new trip will start by arrival to geo-fences or by leaving geo-fences. 

•	 In the “Width” field select the field width designed for displaying the splitter name in Trips selector.
•	 In the “Color” field select the splitter name color. The splitter names are color highlighted in the 

trip grouping mode in Trips selector.
•	 Then the splitter needs to be set up.

To delete a splitter, click  button in the splitter description string. If several splitters are set, 
then the track will be split into trips first based on the first splitter, then based on the second 
splitter, etc., according to the order in which the splitters are listed. To move a splitter in the list, 
use buttons .

Setup of splitter
Splitter settings appear under the splitter list when a splitter is selected. 

To set up a splitter:
•	 In the “Description” field of the “Splitter settings – ...” table enter a trip name, for example, “Shift 

1”, (Fig. 98, item 4).
•	 In the “Start new trip” field set the condition for start of a new trip. Depending on the type of 

splitter, a date and time, week day or month, sensor status, etc. can be the trip start condition.
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•	 Similarly set the trip completion condition in the “Finish current trip” field. The trip completion 
criterion also depends on the splitter type. For some splitter types the trip completion condition 
may be missing (for example, for the “By condition” type). It means that the trip will continue so 
far as the condition set as the start for that trip is true.

•	 Depending on the splitter type, the “On” field may be available. It allows including a final trip 
point into the trip (if the check box is selected), for example, if the trip is completed at 9 pm, 
then the coordinate entry with that time will be included into the current trip, if the “On” option 
is enabled. If a the time span between two trips is not included into the trip, then that span will 
be excluded from the trip time and will not be considered during calculation of the final values 
of vehicle parameters over the trips. 

To perform splitting over trips based on the selected splitter, it is sufficient to set the trip start and 
completion criteria for that splitter. But for a more accurate data processing the trip merging and 
cutting conditions may be set up. 

Trip merging
The trip merging feature allows merging short trips which may occur due to incorrect data, for 
example, coordinate deviations, jitter or accidental sensor switching, etc.

To set up the trip merging conditions, set the trip merging conditions in splitter settings in the 
“Joining by minimal” field (joining based on the minimum value). A trip may be merged with some 
other trip based on minimum vehicle haulage for that trip (the “Dist., m” field) or based on the 
minimum trip duration (the “Duration” field). If both criteria are set, then the trip will be merged 
with the other trip only if both criteria are fulfilled – the trip duration is less than the minimum one 
and the vehicle haulage for that trip is less than the set minimum distance. 

A trip may be merged either with the previous trip or with the next one. These parameters must be 
set up in the “Mer. with” (Merge with) field.

Trip cutting
The trip cutting feature allows cutting a part of trip based on the desired parameter. 

To cut a trip, select the trip cutting condition in the “Cutting based par.” (Cutting based on a 
parameter) field. The status of some vehicle parameter may be the cutting condition. It is possible 
to set cutting of both start or end of the trip, and both points. 

If the trip start cutting condition is set, then a trip part will be cut beginning from the trip start to 
the point in which the set cutting condition was still fulfilled. Similarly, a trip is cut, if the trip end 
condition is set. 



AutoGRAPH 5 PRO • USER MANUAL 77

TechnoKom © 2016

•	 Trips selector is a separate module responsible for splitting the data into trips. Using Trips 
selector the user can view the data for the desired trip. If a separate trip is selected in the modules 
connected to Trips selector, only data for that trip will be displayed. 

•	 Device selector is the data source for the Trips selector. Depending on the data sorting method 
selected in Device selector, Trips selector carries out splitting into trips of either the whole track 
from the selected file (if the “Files” view is selected), or a part of track covered by the established 
calculation time span (if the “Time span” view is selected). The calculation time span must be set 
up in Time span selector. 

•	 If several Device selectors are installed in the scheme, and Trips selector is connected to several 
Device selectors, then the window for selecting the required Device selector becomes available 
in Trips selector (Fig. 99, item 2).

•	 The list of trips performed over the selected time span is presented as a table where rows are 
trips and columns are different vehicle parameters for each trip (Fig. 99, item 5). 

•	 The total row is displayed at the bottom of the list. It shows the total value of the vehicle parameters 
over the whole data display time span (Fig. 99, item 6). To show the total row, right-click the trips 
list and select the “Show total row” command in the menu that appears. Re-selection of the 
command hides the total row.

DISPLAY TRIP DATA
When the data is selected for displaying in Device selector, Trips selector splits this data into 
trips according splitter settings automatically. Trips selector cursor is placed over the initial trip 
automatically according to the trips list settings. To set up the initial position of Trips selector 
cursor, go to the section Behavior > Trip list settings in the “Options” menu. Then select the initial 
cursor position on the “Parameters” tab in the trips list (Fig. 100).

Fig. 99. Trips selector.

TRIPS SELECTOR
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Fig. 100. Initial Trips selector cursor position.

•	 First entry of the first trip – the cursor is placed over the first trip in the trips list, the cursor being 
placed over the first entry of that trip in the modules connected to Trips selector. 

•	 First entry of the last trip – the cursor is placed over the last trip in the trips list, the cursor being 
placed over the first entry of that trip in the modules connected to Trips selector. 

•	 Last entry of the last trip – the cursor is placed over the last trip in the trips list, the cursor being 
placed over the last entry of that trip in the modules connected to Trips selector. 

To select the desired trip, left-click on that trip. When a trip is selected, the following occurs:  

•	 the track over the selected trip will be displayed in Map Viewer. In this case Vehicle cursor is set 
to the initial track point.

•	 The stages for the selected trip will be displayed in Stages viewer.
•	 Graphs and charts for the selected trip will be plotted in Chart Viewer. 
In this case viewer cursor will be placed over the point (entry) determined by settings of the initial 
position of Trips selector cursor. 

After selection of the trip for going to the first entry of the selected trip right-click on the trips 
list and select the “Go to initial entry” command. This command will set the viewer cursors to the 
entries corresponding to the first point of the selected trip. To go to the first trip entry, one may 
alternatively click Enter. 

After going to the last entry of the selected trip right-click on the trips list and select the “Go to 
final entry” command. The last entry related to the selected trip will be selected in the modules 
connected to Trips selector. It is also possible to go to the final trip entry using the “Enter+Ctrl” key 
combination.
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Fig. 101. Trip colouring based on the switch status.

The data can be split into trips based on several splitters. The splitter names are displayed in the 
“Trips” column in the trips list. The splitter priority is set up during splitter setup. The user can 
individually disable the splitters. For this purpose, disable the unnecessary splitters by de-selecting 
check boxes in Trips selector in the “Split into” list (Fig. 99, item 1). The splitter group is also selected 
in this menu. 

To disable data splitting into trips, click the “Split into trips” button on the toolbar of Trips selector 
(Fig. 99, item 4). Re-clicking the button resumes splitting. 

TRIP COLOURING
Colouring of trips in the trips list with assignment of different colors based on different criteria is 
provided. The trip colouring can be performed using the following methods:

1.	Based on a switch operation. 
If the vehicle switch was activated during the trip, then that trip will be highlighted with a color assigned 
for the activated status into which the switch was turned during that trip. The switches are set up in the 
“Calculation parameters” section of the “Devices” menu (Fig. 101). A switch must be a trip parameter.  
Then go to the “Options” menu to the section Appearance > Trips list colouring and specify the 
switch determining colouring of Trips selector rows (Fig. 102, item 1). For this purpose, enter the 
required parameter name in the “Parameter  name for colouring rows” and select a value of that 
parameter which will be checked: 

Switch is a vehicle parameter which is characterized by two statuses (ON and OFF). This parameter can be used 
to display operation of different sensors connected to the vehicle or displaying flags. The switch can have several 
on statuses, for example, the switch showing GLONASS / GPS signal status can have ON statuses “standard level” 
and “low level”, OFF status – “no signal”. 

IMPORTANT
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Fig. 102. Trip list colouring setup.

•	 Curr. – in this case all switch values will be checked, and if the switch triggered at least once 
during the trip, then the row of that trip will be colored in accordance with the respective 
parameter status.

•	 First – in this case only the first value of the switch for the trip is checked. The other values are 
not checked. If the switch was off in the trip start point, and during the trip it was switched to on 
state, then the trip row with such setting will not be colored according to on status of the switch.

•	 Last – in this case only the last value of the switch for the trip is checked. The other values are 
not checked. If the switch was off in the trip end point, and during the trip it was switched to ON 
status, then the trip row with such setting will not be colored according to on status of the switch.

An example of the trip row colouring according to on status of the switch is shown in Fig. 103, item 
1.

2.	In Trips selector the table columns colouring can be set in accordance with the colors of graphs 
of parameters the values of which are displayed in these columns. To enable this option, select the 
check box “Colouring the column by parameter” (Fig. 102, item 2). A colouring example is illustrated 
in Fig. 103 – item 2. 
3.	In Trips selector a parameter value may be highlighted depending on whether that value was 
updated over the trip or was filtered out (Fig. 103, item 3). To set up the text colouring, go to the 
settings section Appearance > Trips list colouring in the “Options” menu and select the “Highlighting” 
tab. In the “Text” group on this tab select colors to highlight the values which were not updated in 
the current trip, and the values which were filtered out (Fig. 102, item 3).
4.	Holiday trips can be highlighted in Trips selector. To set up this type of colouring, set up the 
holiday trips color highlighting in the “Background” group on the “Highlighting” tab (Fig. 102, item 
3). The date and time cell bounding box of holiday trip is color highlighted (Fig. 103, item 4). 
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Fig. 103. Trip list colouring example.

TRIP GROUPING
This feature allows sorting trips by groups depending on splitters. Grouping needs that breakdown 
of data into trips were performed by two and more criteria. Grouping is carried out by based on 
the first splitter. The trip groups are shown in Fig. 104 – the trips are grouped based on the first 
splitter – week days. 

To enable grouping, right-click the trips list and select the “Group trips” in the menu that appears. 
To cancel grouping, de-select the check box opposite the “Group trips” option by selecting this 
option again.
To expand a group, double click the group header or click the arrow opposite the header. To 
collapse all groups, click the “Collapse” button on the Trips selector toolbar (in the upper right 
corner).

Fig. 104. Trip grouping.
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Group headers
In the Trips selector shortcut menu (called by right-click on the trips list or through the toolbar) 
select the “Group rows view” command, then select the required header view. By default the group 
header view is ordinary – the header contains the name of the splitter based on which grouping is 
carried out and the time span covered by the group.

In addition, the user can set up the header format for each group rows view. For this purpose, go to 
the settings section Appearance > Trip group rows display format in the “Options” menu and select 
the “Group rows formats” tab (Fig. 105). It is recommended to set up the header format for each 
view using conventional designations detailed below. 

Conventional designations used in Trips selector: 
{0} – splitter description. For example: “Day”.
{1} – internal index of the splitter entry. 
{2} – splitter entry description. For example, “Monday”.
{3} – initial date and time of the trip. For example, “24/06/13 00:00:00”.
{4} – final date and time of the trip. 
{5} – initial file name. For example, “9999998-130624.sbin”
{6} – final file name. 
{7} – position of the first entry of trip in the file. 
{8} – position of the last entry of trip in the file.
{9} – number of (trips) subentries in the group. 
{10} – initial date and time based on the splitter.
{11} – final date and time based on the splitter. 

Fig. 105. Group header format.
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SETUP OF COLUMNS IN TRIP LIST
By default standard set of columns is displayed in Trips selector – all vehicle trip parameters and 
parameters for which the display of final values in Trips selector is set up. Also a fixed columns view 
is provided in Selector. It allows displaying the user set of columns. To switch to the fixed view, click 
the “Fixed columns” button on the Trips selector toolbar. 

Fig. 106. Edit columns menu.

To set up columns – add new or delete 
undesired – go to the “Columns edit” menu by 
clicking the “Columns edit” button on the Trips 
selector toolbar. An example of the “Columns 
edit” menu is shown in Fig. 106.  
The “Columns edit” menu contains a list of 
parameters which can be added to the trips list 
– it is the list of all trip parameters of the device 
selected in Device selector. 
To add a parameter from this list into the trips 
list, select the check box for this parameter. To 
delete a parameter from the trips list, de-select 
the check box for this parameter. 

To create a new column:
•	 Click the “Add custom column” button on the toolbar (upper bar) in the “Columns edit” menu 

(Fig. 106).
•	 Then in the “Band name” field of the menu that appears (Fig. 107) select a band header from 

the list of offered headers. A band is a column shared by several parameters. For example, the 
“Sensors” band may be shared by individual columns with different sensors. A column may be 
without a band. The user can also create new bands (see the instruction below).

Fig. 107. Adding a new column.
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•	 Then set up the column properties:
•	 Select a column parameter determination method by name (description) or by alias.
•	 Enter parameter name or alias, depending on the selected parameter determination method, 

into the “Parameter name or alias” field.
•	 Select a parameter value type which will be displayed in the trips list: current value, the first 

value over the trip, the last value over the trip, or difference of the first and last values over the 
trip.

•	 In the “Rows count” field set up the quantity of rows assigned for the parameter.
•	 Click the “Add” button to add a new column with the selected settings. After that the new column 

will appear in the trips list.
To delete a column, right-click this column and select the “Delete column” command.
To edit the column properties, right-click this column and select the “Edit column” command, then 
set up the column properties in the menu that appears. 

To add a new band:
•	 Click the “Add custom band” button on the toolbar in the “Columns edit” menu.
•	 Then enter the band name into the “Band text” field of the menu that appears, and set up the 

translation table.
•	 To add a new band with the selected settings, click the “Add” button. The new band will be added 

to the list of trips. 

To delete a band, right-click the band in Edit columns mode and select the “Delete band” command 
in the column that appears. To edit a band, select the “Edit band” command in the same menu. 

Preset column views
There are three preset column views in the program. They allow determining the trips list column 
view. 
To select a preset view, click the “Default presets” button on the toolbar in the “Columns edit” 
menu. The following default presets are available in this menu (Fig. 108):
•	 Preset: Classic fixed columns – allows restoring the standard column view including a fixed set 

of columns determined by the program. The standard view allows restoring the trips list view 
similar to the trips list of AutoGRAPH 4.0 Dispatch Program.

•	 Preset: All device parameters – allows adding all trip parameters of the selected vehicle to the trips 
list, and the parameters for which display of final values is set up in Trips selector. 

•	 Preset: Empty – allows deleting all columns from the trips list (except columns with trip 
description). 

After setup of the column view, to save changes click the “Apply” button in the “Columns edit” 
menu. In shortcut menu of the “Apply” button it is possible to select objects to which the changes 
will be applied – the “Apply to current” command applies the new column configuration to the 
vehicle which is highlighted in Device selector. The “Apply for the whole group” command applies 
changes to the whole parent group of the highlighted vehicle. 
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Fig. 108. Column default presets.

EXPORT AND PRINT OF TRIPS LIST
Export of trips list
The trips list can be exported to external files. For this purpose, right-click the trips list and select 
the “Export to” command in the menu that appears (Fig. 109). Then select a format of the file to 
which the trips list will be exported. After export the final file will be opened automatically.

Fig. 109. Trips list export.

Copying the trips list via the clipboard
The desired trips list rows may be copied to the clipboard and pasted to the desired file. For this 
purpose, select the desired rows. Then right-click the trips list and select the “Copy selected rows” 
command in the menu that appears. The selected table rows will be copied to the clipboard from 
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where these rows can be pasted to any file. 
Selecting several rows is carried out using “Ctrl+left click”1 or “Shift+left click”1 key combinations. 
The rows can also be copied using the “Ctrl+C” key combination.

Print of trips list
The trips list can be printed. To print the trips list, right-click the trips list and select the “Print” 
command. After that the print list preview window will appear. The user can set up paper size and 
other print properties in this menu. To send a file to printer in preview mode, select “File – Print...”

TRIP PARAMETER CALCULATION
The AutoGRAPH 5 PRO program allows calculating the vehicle parameter values for individual 
trips. The trip parameters must be added to the program via Device data handler. 

TRIP PARAMETER CREATION
To create trip parameters, go to the “Devices” menu; for this purpose, select Menu bar > Tools > 
Devices...
In the “Devices” menu select a vehicle or vehicle group for setup, then go to the settings section 
Calculation > Calculation parameters and select the “Parameters list” tab (Fig. 110).

Fig. 110. Setup of the trip parameter.

1 Left click is a single click of left mouse button. 

The list of parameters calculated in the AutoGRAPH 5 PRO program is presented on this tab.
Then add the desired parameter to the parameters list and select the “Trip” item in the “List” field. 
Such setting means that the parameter will be displayed in the trips list after calculation. 
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DISPLAYING FINAL PARAMETER VALUES IN TRIPS SELECTOR
The final values can be displayed in Trips selector. To set up the final values, select a parameter for 
setup in the parameters list and go to the “Totals” tab (Fig. 111). Then select a value which will be 
displayed in total row of Trips selector – for this purpose, enable the “Using in total parameters 
lists” option, and select a parameter value for displaying in the table below, checking the items in 
the “Trip” column.

The trip parameters are added to the final list of Trips selector automatically, so the final values 
table is unavailable for the trip parameters. 
For trip parameters select a method for calculating the final value in the “Totals” list. (Fig. 112).

Fig. 111. Final values of parameter over the trip.

Fig. 112. Total values of the trip parameters.
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TRACK SEGMENTS
A track breakdown into stages based on different vehicle parameters can be set up in the 
AutoGRAPH 5 PRO program. The stage start and end are based on the parameter status change. 
The vehicle parameter based on which the track will be broken down into stages shall be set up as 
a switch. Then this parameter must be set as a condition for breaking down the track into stages. 
The track breakdown into stages based on switch statuses is carried out by Stages viewer. 
The switch setup procedure and the track breakdown into stages based on statuses of that switch 
are detailed in this section of Manual below. 

STAGE PARAMETER CREATION
To create a parameter based on which the track will be broken down into stages, go to the “Devices” 
menu. In this menu choose a vehicle or vehicle group for setup, then go to the settings section 
Calculation > Calculation parameters and select the “Parameters list” tab (Fig. 113).
To add a program to the program for breakdown of a track into stages proceed as follows.
1.	Add a new parameter with the “Switch” type to the parameters list, specify an expression for 
calculating the parameter and set up other properties (Fig. 113, item 1).
2.	Set the switch status on the “Switch statuses” tab (Fig. 113, item 2) – set the status description, 
values, images and other parameters. 
If the parameter does not have the “Switch” type, or statuses for the switch are not set, then no 
breakdown of the track into stages will be possible. 

Fig. 113. Creation and setup of the stage parameter. 
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STAGES FILTRATION
After creation and setup of the switch set that switch as a filter for Stages viewer. For this purpose, 
go to the “Stages” section in the “Options” menu and select the “Stages tabs” tab (Fig. 114). Stages 
set up in the current scheme are listed on this tab. 
To add a new stage:

Fig. 114. Stages tabs in the Stages viewer. 

•	 Enter the stage name in the blank row of the “Name” field. The stage name is displayed in reports, 
in Stages viewer tab header and in other viewers. 

•	 In the “Image” field choose a stage icon which will be displayed on the track for designation of the 
stage and in Stages viewer tab header. 

•	 In the “Filter” field choose the filtration method:
Any parameter – this filter allows displaying in Stages viewer all stages available in the scheme. 
When this filter is chosen, a list of available stages will appear in Stages viewer. The user can 
choose a desired stage there.

Group – this filter allows displaying the selected stage group in Stages viewer. In this case the 
list containing all stages of the selected group will be available in Stages viewer. The user will be 
able to select the desired stage in that list. To carry out filtration based on the desired group, set 
that group’s name in the “Group / parameter” field. The group name is displayed in the “Options” 
menu, the “Calculation” section, in calculation parameters list (Fig. 115). 
Parameter – this filter allows displaying stages of only one parameter based on that parameter’s 
name in Stages viewer. To carry out filtration based on the desired parameter, set that parameter’s 
name in the “Group / parameter” field, for example, GeoFence1, Park, etc. 
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Fig. 115. Parameters group name.

Alias – allows filtering based on the parameter alias. For this purpose, set that parameter’s alias in 
the “Group / parameter” field. The alias can be set up in general settings of parameters. When a 
parameter is added via Designer, the alias is assigned automatically. 

Format “Parameter*”, where Parameter is the name or alias of the parameter, allows filtering for 
all switches which begin with the “Parameter” string. For example, if GeoFence* string is specified 
in the “Group / parameter” field, then stages of all parameters beginning with the “GeoFence” 
string, for example, GeoFence1, Geofence3, Geofence_4, GeoFenceTerminalPoint2 will be listed 
in Stages viewer. When such format is used, an option for selecting the desired stage will be 
available in Stages viewer. 

STAGES LIST
Stages viewer allows breaking down the selected vehicle’s track into stages based on the set up 
switches. When selecting data for displaying Stages viewer breaks down data into stages using 
settings specified for the selected vehicle. The stages are sorted into individual tabs according 
to filters set in general settings of Stages viewer. If the parameter or parameter group based on 
which filtering was performed is not found in the vehicle parameters list, then no stages will be 
generated for that vehicle. 
An example of stages list is illustrated in Fig. 116. 
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Fig. 116. Stages viewer.

GENERAL INFORMATION
•	 The list of stages is a table where rows are different statuses of the switch – ON and OFF, columns 

are different vehicle parameters at the time when the parameter was in each state. 

•	 If the track is broken down into trips, then only stages over the selected trip will be displayed in 
Stages viewer. If the breakdown into trips is disabled, then, depending on Device selector data 
sorting method, stages over the selected time span or time span covered by the selected data 
file will be displayed.

•	 Left double click on a stage moves the cursor in viewers to the point (entry) corresponding to the 
segment start, for example, vehicle cursor on the track moves to the stage start. 

•	 If data is filtered in Stages viewer based on several parameters, then the “Parameter” list is 
available in the upper left corner of the viewer window. The user can select the desired stage for 
viewing there. (Fig. 116, item 1). 

•	 The “Show off-state” option (Fig. 116, item 2) allows showing or hiding the stages during which 
the stages parameter was off. Please kept in mind that some switches may have only ON statuses, 
for example, the parameter showing vehicle stops and movement stages. 

•	 In the upper right corner Stages viewer toolbar is located (Fig. 116, item 3).
•	 At the bottom of the list a row with final vehicle parameters over the selected display time span 

is displayed (Fig. 116, item 4). To show the total row, right-click the stages list and select the “Show 
total row” option in the menu that appears. Re-selection of the option hides the total row. 
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COLUMN VIEW / USER COLUMNS
Two column views are provided in Stages viewer: standard column view which allows displaying 
all vehicle parameters and fixed column view which allows displaying the user column set. To 
switch to the fixed view, click the “Fixed columns” button on Stages viewer toolbar (Fig. 116, item 3). 
To set up columns – add new or delete undesired – go to the “Columns edit” menu by clicking the 
“Columns edit” button on the module toolbar. An example of the “Columns edit” menu is shown 
in Fig. 117. 

Fig. 117. The “Columns edit” menu.

FILTERING 
To make the operation convenient, the stage list filtering is organized. It allows selecting stages 
based on the criterion of interest. 
To call the filtration menu, click the “Filter” button on Stages viewer toolbar (Fig. 118). 

The “Columns edit” menu contains a list of 
parameters which can be added to the stages list. 
These are the trip parameters or parameters for 
which the display of final values in trips list of the 
device selected in Device selector is allowed. 

To add a parameter from this list into the stages 
list, select the check box for this parameter. To 
delete a parameter from the stages list, de-select 
the check box opposite this parameter. 

Fig. 118. Filtering stages by numeric parameter.
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In Stages viewer the stages during which the value of the selected parameter was in the set 
range will be displayed. Fig. 118 illustrates an example of the filtration of the stages based on the 
minimum duration – the stages less than 60 seconds are not displayed in the list. Fig. 119 illustrates 
an example of the filtration of the stages based on the sensor status – the stages when the ignition 
was off are not displayed in the list.
It should be note, that only the parameter, totals of those are displayed on Trip lists, can be used 
for the filtration. This option is set up in the Device menu (Fig. 120).

Fig. 119. Filtering stages by discrete parameter.

To carry out filtration, select the vehicle parameter based on which stages will be selected in the 
“Filter by” field. Then:
•	 For numeric parameter set the range of possible values of the selected parameter (the fields 

“from” and “to”), Fig. 118.
•	 For discrete parameter select the status for the filtration (Fig. 119). The discrete parameters – these 

parameters display the Boolean value. 

Fig. 120. Setup of parameter for stages fltering.
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Fig. 121. Stage grouping. 

THE STAGE GROUPING
The grouping feature allows sorting of the stages into groups based on the status of the parameter 
based on which the breakdown into the stages was performed (Fig. 121).
•	 To group the stages, right-click the stages list and select the “Group stages by status” in the menu 

that appears. Re-selection of the option cancels the grouping.

•	 The double-click on the group heading expands the group. The repeated double-click collapses 
the group.  To collapse all the groups, click the “Collapse” button on the Stages viewer toolbar. 

•	 In the group header the quantity of the stages in the group and the parameter stage based on 
which the grouping is performed is indicated (Fig. 121, item 1).

•	 For each group the final values can be calculated (Fig. 121, item 2). To show the total row of the 
group, right-click on the segments list and in the menu that opens select the “Show total status 
rows”, then select the group total row display method: No – hides the total row of the group, 
Expanded – allows displaying the total rows of only expanded groups, All – allows displaying the 
total rows of all groups (expanded and collapsed ones). 
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STAGES LIST COLOURING
For the convenience of the operation the colouring of the stages on different criteria is provided. 
Fig. 122 illustrates an example of stages list colouring. 

Fig. 122. Stages list colouring.

Fig. 123. Stages list colouring setup.

To set up the stages list colouring, go to the settings section Appearance > Stages list colouring in 
the “Options” menu and select the “Highlighting” tab (Fig. 123). 
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The stage colouring can be performed as follows:
1.	Horizontal lines, if there are hidden rows. The rows may be hidden, if the stages filtering is 
performed. The line color is set in the “Horizontal lines” section(Fig. 123, item 1).
2.	The cell text colouring, if the cell value was not updated since the latest data entry (Fig. 122, item 
1), or if the value was filtered (Fig. 122, item 2). The text color for each event shall be set up in the 
“Text” section (Fig. 123, item 2).
3.	Colouring of a cell outline with date and time, if the stage falls within a holiday – Saturday and 
Sunday (Fig. 122, item 3). The colouring color is set up in the “Background” section (Fig. 123, item 3). 
4.	Colouring of the whole stage row based on the vehicle parameter triggering. To color the stages 
list based on the parameter triggering, set the parameter for colouring on the “Highlighting” tab in 
the “Parameter name for colouring rows” field – name or alias (Fig. 122, item 4), then select the value 
of that parameter which will be checked: 

•	 Current – in this case all switch values will be checked, and if the switch triggered at least once 
during the stage, then the row of that stage will be colored in accordance with the respective 
parameter status.

•	 First – in this case only the first value of the switch for the stage is checked. The other values are 
not checked. If the switch is off in the stage start point, and during the stage is switched to on 
state, then the stage row in such a setting will not be colored according to ON state of the switch.

Fig. 124. Stages list columns colouring.

•	 Last – in this case only the last value of the switch for the stage is checked. The other values 
are not checked. If the switch is off in the stage end point, and during the stage is switched to 
ON status, then the stage row in such a setting will not be colored according to ON state of the 
switch.

If the selected parameter is in ON state in the checked stage point, then the row of that stage will 
be highlighted with color which is set for ON state of the parameter in settings of that parameter 
(in parameters list of the “Devices” menu). Fig. 122 (item 4) illustrates an example of the stage list 
colouring based on triggering of the overspeed parameter.  

5.	Colouring of a column with the color set for the graph of this column. To enable the column 
colouring, enable the “Colouring the column by parameter” option on the “Highlighting” tab (Fig. 
123, item 5). An example of colouring for stages list columns is shown in Fig. 124.
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1 Left click is a single click of left mouse button. 

PRINTING AND EXPORT OF STAGES LIST

Stages list export
The stages list can be exported to external files. For this purpose, right-click the stages list and 
select the “Export to” command in the menu that appears. Then select a format of the file to which 
the stages list will be exported. After export the final file will be opened automatically.

Copying the stages list via the clipboard
The desired stages list rows may be copied to the clipboard and pasted to the desired file. For this 
purpose, select the desired rows. Then right-click the stages list and select the “Copy selected rows” 
command in the menu that appears. The selected table rows will be copied to the clipboard from 
where these rows can be pasted to any file.
Selecting several rows is carried out using “Ctrl+left click”1 or “Shift+left click”1 key combinations. 
The rows can also be copied using the “Ctrl+C” key combination.

Stages list printing
The stages list can be printed. To print the stages list, right-click the stages list and select the “Print” 
command. Then the preview window for the list to be printed will appear. The user can set up 
paper size and other printing properties in this menu. To send a file to printer, select File > Print... 
in preview mode.

VIEWING STAGES ON THE MAP
The stages can be displayed on the track. 
To display the track stages on the map, click the “Track segments” button on the bottom toolbar 
of Map Viewer (Fig. 125).

Fig. 125. Setup of the track segments display on the map. 
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In the “Track segments” button shortcut menu the user can select stages to be displayed on the 
track, and hide the unnecessary ones. 

The stage start is represented by an 
icon assigned for that stage. Left-click 
on the stage icon displays information 
about the stage.

Fig. 126. Information about the stage start point.

The additional information about each stage can be displayed on the track along with the stage 
icon. To set up the stage labels, go to the section Appearance > Stages and geo-fences in the the 
“Options” menu and select the “Stages” tab (Fig. 127). 

Fig. 127. Setup of stage labels.

The stages can have the following labels:
•	 Index – sequential number of the stage (Fig. 128, index 10). The index is used to search for a desired 

stage in viewers synchronized with Stages viewer. 
•	 The stage start and end times (Fig. 128, start – string s:, end – string e:).
•	 Duration of the stage (Fig. 128, string d:). 
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Fig. 128. Example of stage labels. 
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VEHICLE STATUSES
The AutoGRAPH 5 PRO program allows establishing the vehicle statuses – the vehicle status 
change command is sent to the server by the dispatcher from the AutoGRAPH 5 PRO program. 
The vehicle statuses are recorded to a .route file. The status change time is recorded with the status 
to such a file. Each week a new .route file is created on the server. The file is created when a status 
is set in the Dispatch Program, then all operations with statuses within a week are recorded to that 
file. The .route file is loaded into the Dispatch Program along with the vehicle data. Once the .route 
file is loaded, the information from that file can be used in reports. 

LIST OF AVAILABLE STATUSES
The AutoGRAPH 5 PRO program contains a list of standard statuses. To view this list, go to the 
Status types section in the “Options” menu (Fig. 129). 
Each status has its individual identifier (the “ID” field).

Fig. 129. Standard statuses.

The statuses with identifiers from 0 to 9 are statuses of AutoGRAPH-NAVIGATOR device, the 
standard identifiers of these statuses in the program match the identifiers set in AutoGRAPH-
NAVIGATOR. 

The program users can add new statuses to this list, change identifiers (including identifiers 
for AutoGRAPH-NAVIGATOR statuses) and descriptions of the existing statuses or delete any 
unnecessary statuses. 



AutoGRAPH 5 PRO • USER MANUAL 101

TechnoKom © 2016

To add a new status:
•	 Place the cursor over the “Description” field in the empty row and enter the status description.
•	 In this case a unique consecutively numbered identifier will be automatically assigned to the 

new status, then the list will be sorted by ascending of identifiers.
•	 To change the status identifier assigned by default, place the cursor over the “ID” field and change 

the field value. After the change is applied, the list will be sorted by the status identifiers. 

To delete a status, click the  button in the “ID” field (Fig. 130, item 1). 

Fig. 130. Deleting the status and translation table.

A table of translations into other languages supported by the AutoGRAPH 5 PRO program can 
be set up for the status description. To edit the table of translations, click the  button in the 
“Description” field (Fig. 130, item 2). The table of translations allows correct translation of the status 
description into other languages during switching of the AutoGRAPH 5 PRO program interface. 

To use the status from the list of available ones in the program (apply to the vehicle and use in 
calculations), select the check box for this status (Fig. 131). 

Fig. 131. Enabling a status.
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Fig. 132. The “Set status” menu.

SETTING STATUS
All statuses with selected check box in the list of the available statuses will appear in the “Set 
status” menu on the control bar (Fig. 132). 

To set a status:
•	 Select the desired vehicle in Device selector.
•	 Click the “Set status” icon on the control bar, 

then select a status to be set in the drop-down 
list.

•	 A vehicle status change command will be sent 
to the server. The communication log between 
Dispatch Program and a server will appear in the 
Online devices provider status window. 

If the control bar is hidden, then it is also possible to change the vehicle status via the Device 
selector shortcut menu. For this purpose, right-click on the desired vehicle and select the “Set 
status” command in the shortcut menu, then select a status to be set in the drop-down list. 

Fig. 133. Setting a vehicle status via Device selector.
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STATUS REQUESTING AND PROCESSING
The .route files with information about the vehicle status change are loaded into the Dispatch 
Program along with other vehicle data (.bin/.sbin files) and recorded into \Data file. Then the 
statuses become available for use in calculations; the statuses can be used in expressions, for 
splitting into trips and stages, in reports, for displaying on a vehicle track as icons, etc. 
The following key parameters for processing the statuses from .route file are provided in the 
AutoGRAPH 5 PRO program:
•	 RouteStatus – the status for the tabular parameters. The parameter returns the set status identifier 

according to the respective .route file and can be used for breaking down the track into trips, 
generating stages, etc. 

•	 LastRouteStatus – the status for the final parameters.
•	 LastRouteStatusDT – time (local) when the latest status was set.

When the vehicle status is set in the Dispatch Program, this status will be applied to the data, 
beginning with an AutoGRAPH device entry following the status setting. Therefore, to display the 
new vehicle status in the Dispatch Program immediately after the setting, even if the new have 
not been recorded by an AutoGRAPH device, the final parameter LastRouteStatus is provided. The 
parameter LastRouteStatusDT shows the time of the latest status. 
The current AutoGRAPH 5 PRO software version does not support the automatic update of the 
vehicle status generation based on identifiers, so set up the enabled statuses for the RouteStatus 
parameter to display the current status – icon and description instead of the status identifier. For 
this purpose:

•	 Go to the section Calculation > Calculation parameters in the “Devices” menu (Fig. 134). 
•	 If the parameter RouteStatus is not added to the list, then add this parameter and set it up as a 

switch (Fig. 134, item 1).
•	 On the “Switch statuses” tab, in the “ON states are defined by list of” row select setting of the 

“Conditions” (Fig. 134, item 2).
•	 Then add the vehicle statuses to the “ON states” table; specify the status description in the 

“Description” field and enter the status identifier in the “Value” field (Fig. 134, item 3). 
•	 If the status is not added into the ON states table, then only its identifier will be displayed when 

setting this status in the program. Also this status will correspond to OFF state of the parameter 
RouteStatus. 

Since a new status is applied to those AutoGRAPH device data which follow the status entry, at 
repeated change of the vehicle status in the interval between the neighboring entries of an 
AutoGRAPH device only the last set status will be recorded. Any intermediate switching will be 
ignored since there are no respective entries which the intermediate statuses could be associated 
with. 

IMPORTANT
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Fig. 134. Setup of a parameter for status display.

GENERATION OF STAGES BASED ON STATUS CHANGE
Further, to obtain a detailed report, the statuses parameter can be used to split a track into stages 
based on different statuses. For this purpose, set up as follows:
•	 Go to the Stages section in the “Options” menu (Fig. 135).
•	 On the “Stages tabs” tab add a new stage and perform filtering by parameter RouteStatus (Fig. 

135).
•	 Save the settings.

Fig. 135. Setup of the status tab for Stages viewer.
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Fig. 136 illustrates an example of splitting a track into stages based on statuses.

Fig. 136. Track segments based on statuses.

To display stages on the map, enable displaying the statuses parameter in Map Viewer, the “Track 
segments” menu (Fig. 137). 

Fig. 137. Displaying status stages on the track.

The stages on the track are highlighted with icons of the respective statuses and labels, if displaying 
labels is enabled in Map Viewer settings. Left-click on the stage icon displays information about 
the stage (Fig. 138). 
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Fig. 138. Status stages on the track.

SPLITTING INTO TRIPS BASED ON STATUSES
The parameter RouteStatus can be used for generation of trips. To set up the trip splitter: 
•	 Go to the section “Trip splitters” in the “Devices” menu (Fig. 139). 
•	 Add a new splitter with the “By change status” type (Fig. 139, item 1).
•	 In the splitter settings add a new trip and set ReouteStatus parameter (the switch showing the 

current vehicle status) as a condition for start of this trip (Fig. 139, item 2). 
•	 Save the settings.

Fig. 139. Setup of the trip splitter based on the vehicle statuses. 
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Fig. 139 illustrates an example of splitting the data into trips based on the vehicle status change. 
For convenience the user columns and a column with the current vehicle status can be displayed. 

Fig. 140. Splitting into trips based on statuses.

The columns in Trips selector are trip parameters or tabular parameters for which the display of 
the final values in the trips list is set up. So, set up the display of the final value for the parameter 
RouteStatus in the trips list to display the vehicle status column in Trips selector (Fig. 141). 

Fig. 141. The “Devices” menu, the “Calculation parameters” section. 
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MULTI TRIPS AND MOBILE CP
The multi trips feature allows displaying tracks of several vehicles per trip on the map. The multi 
track plotting principle is based on generation of the track over the main vehicle’s trip and plotting 
tracks of additional vehicles against the main vehicle’s track. It means that the additional vehicles’ 
tracks are generated over the time span covered by the main vehicle’s track. The breakdown into 
trips is performed also based on the main vehicle’s settings. 

MULTI TRIPS
To build multi tracks:
•	 Go to the section Appearance > Vehicle columns and items showing, items order in the “Options” 

menu, then disable the “Hide check boxes” option on the “View” tab (Fig. 142). The check boxes 
of Trips selector are necessary for selection of the devices which tracks will be displayed on the 
map. 

Fig. 142. Setup of Trips selector for viewing multi trips. 

•	 Enable the multi trip mode in Trips selector by clicking the “Multi trips” button in the right upper 
corner of the module window (Fig. 143). This mode allows breaking down the track trips of several 
vehicles. 

Fig. 143. Enabling multi trip mode. 
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•	 In Trips selector select the data of the main vehicle against which other vehicles’ track trips will 
be split (Fig. 144, item 1). 

•	 Select check boxes of additional vehicles which will be involved in plotting the multi trips (Fig. 
144, item 2). 

Fig. 144. Selection of a vehicle for plotting multi tracks. 

•	 If several Device selectors are installed in the scheme and all of them are connected to the same 
Trips selector, then the multi trips are generated for all Device selectors and vehicles selected in 
these selectors. It allows using one Device selector to select the main vehicle, and the other to 
select additional vehicles. 

•	 After selection of the main and additional vehicles select a trip to view. Tracks of the main vehicle 
and additional vehicles over the selected trip will appear on the map. The vehicle positions are 
displayed on the map using cursors. The main vehicle’s cursor is highlighted with a bounding box 
(Fig. 145, item 1). The additional vehicles’ cursor have no bounding box (Fig. 145, item 2).

•	 If the selected vehicle does not have the data over the time span covered by the trip of the main 
vehicle, then this vehicle’s cursor is not displayed on the map. 

•	 If the vehicle cursor is beyond the visible area of the map, then the direction to position of this 
cursor is indicated with an arrow on the map. Left double-clicking on the arrow centers the map 
in relation to vehicle cursor to which the arrow pointed. 

•	 For convenience of operation in multi track mode, individual track settings may be specified for 
each vehicle (color for colouring, line thickness, etc). 

•	 When the main track point is clicked, a pop-up message with all vehicle parameters in this point 
appears. For an additional track the pop-up message contains the minimum data set (time, point 
coordinates and vehicle speed in this point). 

•	 The stage icons may be displayed on the tracks. In the “Track segments” menu on the bottom 
toolbar of Map Viewer it is possible to select the stages which will be displayed on the main and 
additional tracks if parameters of these stages are set up for additional vehicles.
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Fig. 145. Multi tracks.

•	 Using Viewer player, it is possible to playback the multi tracks. Playback of additional tracks is 
carried out in relation to the main one; cursors of additional vehicles are synchronized with the 
main vehicle’s cursor. For example, if the “Skip parks” option is enabled, then only the main track’s 
parks will be skipped during playback. In this case the additional vehicles’ cursors will jump over 
to the points corresponding to the latest points of the main track’s parks.

•	 If the main vehicle’s cursor is beyond the visible area of the map at the beginning of the playback, 
then the map will be automatically centered in relation to the main vehicle’s cursor.

•	 When the playback is disabled, movement of one cursor moves cursors of other vehicles to 
the points corresponding to the selected point – when the main vehicle’s cursor moves, the 
additional vehicles’ cursors move also, when one of the additional vehicles’ cursor moves, the 
main vehicle’s cursor and other additional vehicles’ cursors move. 
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MOBILE CHECKPOINTS
A mobile checkpoint (CP) is a moving object without fixed coordinates. Mobile CPs are used to 
check for approach of a monitored object with the other moving object. The mobile CPs are widely 
used for monitoring the agricultural machines’ operation. The monitored object may be a freighter 
which approaches a mobile point, for example, a combine harvester to discharge the contents of 
the combine harvester’s grain hopper, or a fuel-servicing truck.

The mobile CPs operate in multi trip mode – the additional CPs are mobile CPs, and the stages of 
approaching with mobile points are generated for the main vehicle. 

To enable the mobile CPs into data processing:
•	 Go to the “Device” menu.
•	 Select a vehicle which will be the main vehicle when plotting multi tracks.
•	 Go to the settings section “Calculation – Calculation parameters” and select the “Designer” tab.
•	 On the “Designer” tab select Table parameters in Common settings group and enable the “Detect 

mobile checkpoints” option (Fig. 146).
•	 Save the settings.

Fig. 146. Setup of mobile CP detection.

Then enable the multi trip mode. For this purpose, click the ”Multi trips” button in the right upper 
corner of Trips selector (Fig. 143). Then plot the main vehicle’s track and additional vehicles’ tracks 
(mobile CPs). Fig. 147 illustrates the mobile CP’s movement track (POLESSE GS10) and the area 
where the monitored object (Kamaz) approaches the mobile point.
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Fig. 148. Creation of mobile CP parameter stages.

Fig. 147. Approach track 

If the mobile CP detection is enabled in the vehicle’s settings, then MobileCHP parameter will 
be added to the parameters list of this vehicle. It will store the name of the mobile point with 
which the vehicle to be set up approached. Approaching a mobile point is detected, if the 
vehicle approached a mobile CP to the distance less than 10 meters. This threshold is fixed in this 
AutoGRAPH 5 PRO version. 
The MobileCHP parameter supports up to four overlaps of mobile CPs in one point. 

Using Stages viewer, it is possible to generate areas where a vehicle approaches mobile points. 
For this purpose, create a new tab in Stages viewer and set MobileCHP parameter as the stage 
parameter (Fig. 148).
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A detailed report on mobile CPs with which the vehicle approached and the state of vehicle 
parameters will be generated in Stages viewer. 

Fig. 149. Stages where the vehicle approaches mobile CPs.
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VEHICLE ROUTE AUTODETECTION
The AutoGRAPH 5 PRO program supports the feature of automatic detection of the vehicle route 
based on the passed geo-fences. 
This function is useful for monitoring of public transport and delivery service operation, etc.
A route is a list of geo-fences designating the actual points of a vehicle’s route. Therefore, before 
creating a route, the required geo-fences must be added to the scheme. A detailed procedure of 
operation with geo-fences (creation, import and setup) is described in the document “AutoGRAPH 
5 PRO Application Manual: Geo-Fences”.

ROUTE CREATION
To create a route, go to “Devices” menu. Select a vehicle or vehicle group for setup, then go to the 
“Routes” section (Fig. 150). 

Fig. 150. Route list.

The “Routes” menu consists of the following panels:
•	 The selected vehicle’s (or vehicle group’s) route list, Fig. 150, item 1.
•	 Geo-fences of the selected route, Fig. 150, item 2. 
•	 The list of geo-fences available in the current scheme, Fig. 150, item 3. 

To create a route:
•	 Add a new route to the route list – place the cursor over the new string and enter the route name.
•	 Add geo-fences to the list of geo-fences. For this purpose, move the desired geo-fences from the 

geo-fence list of the scheme to the geo-fence list of the route using << button. The geo-fences 
can also be dragged using the left mouse button. To delete a geo-fence from the route geo-fence 
list, highlight the geo-fence and click >> button. 
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•	 Set up the order of passage of the route geo-fences. Moving geo-fences within the list is carried 
out using Up and Down buttons which appear when a geo-fence is selected. A route may only 
be determined if the route points were passed in the listed order: the first listed geo-fence is the 
first route point, the second geo-fence is the second route point, etc.

ROUTE DETECTION
After creation of a route add the geo-fence parameter to the program and assign the route geo-
fences to this parameter to monitor the passage. For this purpose, go to the section Calculation > 
Calculation parameters in the “Devices” tab and select the “Designer” tab (Fig. 151). 

To autodetect a route, the geo-fence parameter needs to check passing of all route geo-fences. If 
at least one route point was not assigned to the parameter, then the route autodetection will be 
impossible. 

IMPORTANT

•	 Enable autodetection of the route by enabling the “Detect routes” option (Fig. 151, item 3).
•	 Save the settings by clicking the “Apply” button.

Fig. 151. Setup of route autodetection. 

On the “Designer” tab:
•	 Add a new parameter to the “Geo-fences” group (Fig. 151, item 1).
•	 Assign the route geo-fences to the parameter. For convenience it is recommended to merge the 

route geo-fences to one group in Geo-fence selector and assign this group to the parameter (Fig. 
151, item 2).
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•	 Once the settings are applied, a new 
switch will be added to Device data 
handler into which the determined routes 
will be recorded (Fig. 152). The switch 
will be enabled if the vehicle route is 
determined. The route search is carried 
out in the vehicle route list. If inside a 
route there is a nested route covering only 
some points of a bigger route, then first 
the external route is detected and then 
the internal one. 

It is also recommended to set up the switch 
status display in the total lists (on the 
“Totals” tab). To display the current route 
name in Trips selector, select check boxes 
of the desired values for the switch in the 
“Trip” column (Fig. 152). Fig. 152. Route parameter.

The route autodetection feature allows splitting a vehicle’s track into separate trips based on 
completed routes. 
For this purpose, indicate activation of the switch into which the automatically determined routes 
are recorded as the start of a new trip (Fig. 153). The setup is carried out in the “Devices” menu. 

Fig. 153. Setup of route-based splitting into trips.
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Fig. 154 illustrates an example of splitting the track into trips based on the vehicle routes. 

Fig. 154. Route trails. 

The route-based splitting of a track into trips allows calculating the vehicle parameters for each 
route, plot graphs and generate reports on the desired routes.

Fig. 155. Route trail chart.
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CHARTS AND GRAPHS
This section of User Manual describes plotting of charts and graphs of various vehicle parameters 
using Chart Viewer integrated into the AutoGRAPH 5 PRO program. 
Prior to operation make sure Chart Viewer is installed in the current scheme. 

GENERAL INFORMATION
•	 When selecting the data for display in Chart Viewer a list of parameter graphs and charts available 

for the selected vehicle is displayed (Fig. 156, item 1).
•	 If the parameter has the “Switch” type, then a status change as a function of time of distance 

chart will be plotted for this parameter (Fig. 156, item 2). If the parameter is not a switch, then the 
parameter vs time or distance graph will be plotted (Fig. 156, item 3). 

•	 Scaling of charts and graphs is carried out using the mouse scroll wheel. 
•	 Left double-clicking on a graph or chart point moves the cursor in viewers to the point 

corresponding to the point selected on the chart. 
•	 Moving a graph or chart along the horizontal axis is carried out using the left mouse button.
•	 By default the graphs and charts are displayed on the white background. To change the 

background color, right-click on the graph area, then select the “Custom back color” in the menu 
that appears and select the desired background color in the “Back color” field (Fig. 157).  

Fig. 156. Chart Viewer.

Fig. 157. Setting the graph background color.
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PARAMETER GRAPH
A graph allows displaying the vehicle parameter behavior as a function of time or distance. To plot 
a graph, the parameter may not have “Switch” type. 

Fig. 158. Plotting a parameter graph.

To plot a parameter graph:
•	 Select the data for displaying in Device selector. If the data in Device selector is sorted based on 

a time span, then also set up a data display time span in Time span selector. 
•	 Select a trip for displaying in Trips selector, if the track is split into trips.
•	 In Chart Viewer select a graph function type (Fig. 158): F(time) to plot a parameter vs time graph, 

or F(distance) to plot a parameter vs distance graph. 
•	 Choose a graph of the desired parameter in the parameters list by selecting the check box (Fig. 

158). 

•	 When the mouse cursor is placed over the graph, a pop-up message appears with information 
about the selected point. 

•	 Several graphs can be plotted simultaneously. In this case the graphs will be superimposed. 
•	 By default all the graphs share the same vertical axis. The standard axis is located on the left. 
•	 If the label of the vertical axis (of ordinates) is set in the parameter settings, then a separate axis 

will be plotted for this parameter’s graph on the right.
•	 Also the parameter graph can be plotted on a separate coordinate grid (Fig. 159). For this purpose, 

specify the following label for the vertical axis: x*label, where x is the name of the new coordinate 
grid; label is the vertical graph axis label. 

•	 To display some other parameter’s graph on a new coordinate grid, specify the similar label – 
x*label, where х is the name of the coordinate grid on which the graph is to be plotted, label is 
the label of the vertical axis for the parameter graph.  
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To set up the parameter graph properties, go to the section “Calculation > Calculation parameters” 
in the “Devices” menu. If the parameter was added to the program via Designer, then go to the 
“Designer” tab, find the desired parameters and set up color, line thickness and label of the vertical 
graph axis (Fig. 160).

If the parameter was added via an extended parameter list, then go to the “Parameters list” tab, 
find the desired parameter in the list, then go to the “General” tab. On this tab specify the vertical 
axis label in the “Ordinate” field, select the graph color and set up the line thickness (Fig. 161). 

Fig. 159. Plotting individual graphs.

Fig. 160. Setup of graph properties in Designer.

IMPORTANT

If the graph line thickness is set to 0, then plotting a graph for that parameter will be unavailable – this 
parameter will be hidden in the parameters list in Chart Viewer. It means that specifying zero graph line 
thickness, the user can hide any unnecessary parameters in Chart Viewer and generate a list of user graphs.
For charts this option is unavailable in the current AutoGRAPH 5 PRO program version.
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Fig. 161. Setup of graph properties in parameters list.

PARAMETER CHART
A chart allows displaying different sensors’ states, flag states and other discrete vehicle’s parameters 
on the time axis or in relation to the vehicle distance.

To plot a parameter chart:
•	 Select the data for displaying in Device selector. If the data in Device selector is sorted based on 

a time span, then also set up a data display time span in Time span selector. 
•	 Select a trip for displaying in Trips selector, if the track is split into trips.
•	 In Chart Viewer select a chart function type (Fig. 162): F(time) to plot a chart as a function of time, 

or F(distance) to plot a parameter vs distance chart. 
•	 Select a chart of the desired parameter in the parameters list (Fig. 162). 
•	 Several charts can be plotted simultaneously. 
When the mouse cursor is placed over the chart, a message appears with information about 
the highlighted chart point. If a graph is plotted in the viewer along with the chart, then when 
the mouse cursor is placed over the chart, a range covered by the selected chart stage will be 
highlighted on the graph (Fig. 162). 

To set up the chart label type, right-click on the plotting area and select the desired label types in 
the menu that appears:
•	 The “Show images” option allows displaying the parameter state icons on the chart. 
•	 The “Show states” option allows displaying the parameter state names. 
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The chart colors, names and icons of states are determined by settings of switch statuses specified 
in the “Devices” menu (Fig. 163). 
If some warning thresholds have been set up for the parameter, then warnings of achievement of 
threshold values will be displayed on the graph. The warning thresholds are set up in Designer. 

Fig. 162. Chart plotting.

Fig. 163. Chart color style. 
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Fig. 164. Warning of achieving threshold values.
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ONLINE MONITORING
Monitor module integrated into the AutoGRAPH 5 PRO program allows online monitoring the 
vehicle parameters. The module checks the online data according to specified rules and if the rule 
is fulfilled, it notified the user. 

CREATION OF MONITORING RULES
To create monitoring rules according to which the online data will be checked, go to the section 
Vehicle control > Monitoring rules in the “Devices” menu and select the “Rules” tab (Fig. 165). The 
rules may be set individually for each vehicle or for the whole vehicle group. 

Fig. 165. Creation of monitoring rules.

To create a rule:
•	 Select a vehicle parameter to be monitored in the “Parameter” field. The parameters list contains 

all vehicle’s parameters added to Device data handler.

•	 Set up the parameter monitoring condition in the “Condition” field, then set up the parameter 
value to be monitored. A monitoring condition may be an inequality, equation, falling within a 
range, or a value list.

•	 In the “Action” field set up the actions which will be carried out when the set rule is fulfilled. 
Left-click on the “Action” field displays a shortcut menu (Fig. 166), in which the user may set up 
the actions and the message format. To set up the actions:

•	 Select the message importance status in the “Severity” field. By default any pop-up messages 
with the “Warning” severity are displayed on the yellow background, and are highlighted yellow 
in the Event log. The pop-up rule notifications with the “Error” severity are highlighted red. The 
ordinary notifications are displayed on the blue background. The user may set any other colors 
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and sounds for each type of messages. For details see “Monitor module settings” paragraph in 
this section. 

•	 To record the Monitor module events in the Event log of AutoGRAPH 5 PRO program, select the 
check box for the “Put record into journal” option.

•	 To display a message in the right bottom corner of the program desktop, select the check box 
for the “Show popup” option.

•	 In addition to recording to the journal and pop-up messages, Monitor module can send 
messages to users by means of different message delivery services. The current AutoGRAPH 5 
PRO program version supports only e-mail sending. 

•	 Sending notifications using ICQ, Jabber, SMS services is only supported by the web server of 
AutoGRAPH, so when creating the monitoring rules for further uploading with the scheme ICQ, 
Jabber, SMS services are available.

•	 To make the module to send a notification when the rule is fulfilled, select the check box of the 
required service, then enter addresses and numbers to which the notifications are to be sent 
with comma separator. 

•	 In the “Ignore duplicates if occur more frequently than once a” field set the minimum interval 
between notifications for a particular rule. Any more frequent notifications will be ignored. The 
interval shall be specified in hh:mm:ss format.

Fig. 166. Setup of actions. 

IMPORTANT

To send e-mails from AutoGRAPH Server, the settings of SMTP server also need to be specified in addition to 
the e-mail addresses. The setup is carried out in the “Options” menu. For details see “Monitor module settings” 
paragraph in this section.
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•	 In the “Message template” field specify the template of a pop-up message and messages sent 
by Monitor module when a selected rule is fulfilled. Examples of the template for different types 
of the monitored vehicle parameters are provided in the “Vehicle control – Monitoring” section 
of the “Options” menu. For details see “Monitor module settings” paragraph in this section. In 
addition to standard messages the user may specify custom message text (fixed text or text 
with variables). The list of available variables and examples of their use are provided in the 
“Vehicle control – Monitoring” section of the “Options” menu. If the template field is left empty, 
then only vehicle name will be present in the notifications sent according to the selected rule. 

•	 Close the menu after setup of the parameters. The settings will be applied to the rule; the 
icons of the selected notifications will appear in the “Action” field, and an icon of the selected 
notification type will appear in the “Type” field.

•	 Then select the check box in the “Enabled in AG.NET” field for the rule to be processed in the 
AutoGRAPH 5 PRO program. The “Enabled in Web” option allows using the rule in AutoGRAPH 5 
WEB after uploading the current scheme to the program. Once the scheme is uploaded to the 
web server, the rules for which the “Enabled in Web” check box is not selected will not be created 
in AutoGRAPH 5 WEB. 

•	 Similarly create and set up all required rules. Then save the settings by clicking the “Apply” or “OK” 
button or in the “Devices” menu. After creation of the rules go to the “Options” menu to set up 
the Monitor module operation.

MONITOR MODULE SETTINGS
For correct operation of Monitor module its operation shall be set up in addition to the monitoring 
rules setup. The module settings are located in the section Vehicle check > Monitoring of the 
“Options” menu (Fig. 167). 

MESSAGE TEMPLATES 
Messages are all pop-up notifications and messages sent to other users via the setup services by 
Monitor module. 
The notification message text is set up when a rule is created in the “Devices” menu. Also, the 
standard messages are provided in the AutoGRAPH 5 PRO program. To set up the standard message 
templates of Monitor module, go to the section Vehicle control > Monitoring in the “Options” menu 
and select the “Message templates” tab (Fig. 167). 
Several templates are provided, depending on the type of the vehicle parameter used in the 
monitoring rule (Fig. 167, item 1). 
•	 Templates for parameters such as Speed, Height, etc are templates for rules designed to compare 

the current parameter value with the maximum threshold. For example, the rule to check the 
speed for exceeding of the 120 km/h threshold.

•	 Templates for parameters with states are templates for the rules designed to check switching of 
the parameter to the desired state. For example, the rule to check the sensor deactivation, the 
vehicle park detection, etc. 

•	 Templates for entering a geo-fence are templates for the rules designed for checking if a vehicle 
entered a geo-fence. 
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•	 Templates for leaving a geo-fence are templates for the rules designed for checking if a vehicle 
has left a geo-fence. 

The automatic pasting of the message template to the rule is unavailable in the current program 
version. Therefore the user can manually copy the desired template and paste it into the rule. The 
Monitor module message templates contain variables instead of which the required values from 
the rules are pasted when the notifications are sent. Using the variables, experienced users can set 
custom notification texts. 
The list of available variables and their descriptions are provided under the message templates 
(Fig. 167, item 2):
•	 {config.parameter} is the parameter name which was checked by the rule, for example, Speed.
•	 {config.parameter-name} is the parameter description which was checked by the rule, for 

example, Current speed.
•	 {config.value} is the threshold value set in the rule settings.
•	 {config.value-to} is the upper threshold value (if the range was set).
•	 {value} is the current parameter value.
•	 {value-prev} is the parameter value in the previous point.
•	 {device.name} is the vehicle name.
•	 {device.id} is the unique internal identifier (ID) of the vehicle (GUID).
•	 {device.group} is the vehicle group name.
•	 {device.group-id} is the unique internal identifier (ID) of the vehicle group (GUID).
•	 {date} is the event date (local).
•	 {time} is the event time (local).
•	 {date-utc} is the event date (UTC).
•	 {time-utc} is the event time (UTC).
•	 {address} is the vehicle address from the address base by the current location.

Fig. 167. Monitor module message templates.
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•	 {property.PROPNAME} is the value of PROPNAME property from the properties registry (for 
example, VehicleRegNumber).

•	 {values.PARAMNAME} is the value of PARAMNAME tabular parameter in the current point.

Example of the message template:
Alert from vehicle {device.group}/{device.name} at {date} {time}:
The vehicle leave the geofence: {value-prev}
Location: {address}
Speed: {values.Speed}

An example of the message based on the above 
template:
Alert from vehicle Root group/Freightliner at 
16/11/2015 11:19:
The vehicle leave the geofence: Warehouse
Location: Lyubertsy, Moscow Region. Lyubertsy 
district
Speed: 61 km/h

SETUP OF THE MAIL SERVER FOR MONITOR MODULE
For the Monitor module to be able to send e-mail notifications, set the parameters of the mail 
server from which the notifications will be sent. For that purpose, go to the section Vehicle control 
> Monitoring in the “Options” menu, select the “Notify settings” tab and set up the mail server. 
There are two types of the mail servers:
1.	Use TechnoKom mail server (Fig. 168). 

Fig. 168. Use TecnoKom mail server. 

In this case the mail will be sent from webmap@tk-chel.ru address via Sendgrid server. No further 
setup is required for this choice. 
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2.	Use other custom mail server (Fig. 169). For that purpose, enable the “Use custom SMTP-server” 
option and set up that server:
•	 Host name or IP is the domain name or IP address of the mail server from which notifications will 

be sent.
•	 Port is the port number which is used for sending mail from the mail server.
•	 Use SSL – this option enables sending mail via a protected channel. Before using SSL make sure 

that the mail server to be used supports the SSL connection. 
•	 Login is the login for accessing the mail server.
•	 Password is the password for accessing the mail server.
•	 Sends mails “From”  is the full e-mail address from which the notifications will be sent.

Fig. 169. Use other mail server. 

When the mail server setup is completed and if the server provided by TechnoKom company is 
used, the user may check the correctness of the specified settings. For that purpose, enter the 
e-mail address to which the test message will be sent in the field “Send test mail to”, then click the 
“Send” button. If the correct mail server data is specified (when using the alternative mail server), 
then a message with text “Test mail” will be sent to the specified address, and a message about the 
successful sending will appear in the menu window (Fig. 170).

iNOTE In the current AutoGRAPH 5 PRO program version sending of test e-mail from the mail server provided by 
TechnoKom company is unavailable.
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Fig. 170. Test e-mail sending.

NOTIFICATION SETTINGS
To set up sounds and colors for notifications, as well as the pop-up message parameters, go to 
the section Vehicle control > Monitoring in the “Options” menu and select the “Appearance and 
behaviors” tab (Fig. 171). 

Fig. 171. Setting of Monitor module notifications.
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Totally three types of notifications are provided. By default the ordinary notifications are displayed 
on the blue background and also are highlighted with blue color in the events log; yellow color is 
assigned to warnings, and red color is assigned to errors. 
By default the sound event notification is not set. On the “Appearance and behaviors” tab the user 
may select any other color for each type of notifications, and select a sound file which will be 
played back with the text notification (Fig. 171, item 1). 
If a sound file is set, then irrespective of whether any pop-up notifications are enabled and whether 

iNOTE The AutoGRAPH 5 PRO program supports playback of .mp3, .wav and .aiff format files.

recording of events to the log is enabled, the sound file set for that particular notification type will 
be played back when the monitoring rule is fulfilled.
If the sound file playback with the notification is not necessary, then clear the “Play sound” field. In 
this case only pop-up message will be used for the notification.
The pop-up notifications are displayed on the background with the selected color. To change the 
background opacity, set the “Background opacity” slider to the desired position (Fig. 171, item 2).  
To display the full path to the vehicle in the vehicle list beginning with the root group in the 
notifications sent by Monitor module – pop-up messages and messages to the selected message 
delivery services, enable the “Show full group path” option (Fig. 171, item 3). For example, if the 
option is enabled, the path to the parent vehicle group will be as follows: Root group/Freighters, 
when Freighters option is disabled.

MONITORING
The rule-based vehicle parameter monitoring is carried out in real-time mode. To start the 
monitoring, click the “Start” button in Monitor module. 
When the online data is received, the Monitor will check the data according to the rule and in case 
of the rule fulfillment it will execute the preset actions:
•	 If pop-up messages are enabled, then a notification on the background the color of which is 

determined by the notification type will appear in the right corner of the desktop.
•	 If a sound file is set for that notification type, then that file will be played back.
•	 If sending e-mails is set up, then notifications will be sent to the specified addresses. The 

notification text is set in the rule settings.
•	 If recording to the log is enabled in the rule settings, then an entry about the respective 

event will be made in Monitor module. All Monitor module events are recorded to 
SQLite base with binding to the current scheme. The events recorded during the current 
session in AutoGRAPH 5 PRO are displayed on the Monitor module “Online” tab (Fig. 172).  
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Fig. 172. The “Online” tab.

The whole log is displayed on the “History” tab (Fig. 173). On this tab the user may set the time 
span (the “Show period from...to” setting) the events in which are to be shown (Fig. 173, item 1). 
Also, using the “Show events with severity” setting, the user may show or hide specific event 
types (Fig. 173, item 2). 

•	 All events in the Log are displayed on the background which is determined by the event type. If 
no text was specified for the event, then the “Message” field will be empty.  

Once the online data is received, Monitor module begins checking the received data based on 
the set rules. A queue is generated to check all the data. The data handling state is displayed in 
the “Events queue” string at the bottom of Monitor module. Then after the data check a message 
queue is generated for sending to the specified e-mail addresses. The message sending state is 
displayed in the “Mail queue” string at the bottom of Monitor module.  

Fig. 173. The “History” tab.
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DOWNLOADING AND DISPLAYING 
PHOTOS
The AutoGRAPH 5 PRO program supports downloading and displaying of the photos received 
from photo cameras connected to AutoGRAPH controllers / AutoGRAPH devices.

DOWNLOADING PHOTOS
Downloading photos is carried out using Online devices provider on the additional panel “Photo 
loader”. The additional panel may be hidden. To show the additional panel of the Online devices 
provider, select Menu bar > Window Menu > Photo loader (Fig. 173). 

Fig. 174. Photo loading from the server.

The Online devices provider supports downloading of photos from the server and from the 
AutoGRAPH controller / AutoGRAPH device. To download photos from the server or the device:

•	 In Device selector select a device or device group which photos should be downloaded.
•	 In Time span selector set the time span over which the photos should be requested.
•	 Go to the Photo loader panel of Online devices provider (Fig. 174). To download the photos from 

the server, go to the “From server” tab. To download photos from a gauge, go to the “From device” 
tab. 

•	 Click the “Refresh photos list” at the bottom of the selected tab (Fig. 174, item 1). The module 
will request the photo list for the selected vehicles over the set time span from the server or the 
device, depending on the selected tab. The received lists will be displayed on the respective tabs. 
When the photo list is requested from the server, the list of photos which are stored only on the 
server will appear on the “From server” tab. When the photo list is requested from the gauge, the 
list of photos which are stored only in the gauge will appear on the “From device” tab. If a photo 
is stored both in the gauge and on the server, then it will be added to the server photo list.
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Fig. 175. Photo loading from the server.

•	 If the photos are downloaded from the gauge, then select the AutoGRAPH gauge type (Fig. 
174, item 2): “AutoGRAPH-GSM” type for on-board controllers or “AutoGRAPH-INFO” type for 
AutoGRAPH-INFO information displays.

•	 After requesting the photo list select the desired photos (Fig. 174, item 3) and click the “Download 
selected” button (Fig. 174, item 4). When the photos are loaded from gauge, they will be 
automatically downloaded to the server and written to the AutoGRAPH 5 PRO program folder.

•	 The user may select any folder for the photo downloading. For this purpose, go to the section 
Folder settings > Folder for photos in the “Options” menu and set the data directory on the 
“Parameters” tab (Fig. 175). 

DISPLAYING PHOTOS 
Photos are displayed in AutoGRAPH 5 PRO by Photo viewer. Photos are loaded into the viewer 
from the same folder into which they had been downloaded from the server and the gauge. 

To display photos, Photo viewer should be set up. For this purpose:   
•	 Right-click in the module window and select the “Edit mode” command in the menu which 

appears. The setup menu appears at the top of the viewer (Fig. 176).
•	 If the numbers of cameras connected to the vehicle are known, select these cameras in the 

“Select cameras” drop-down list. If the numbers of the connected cameras are unknown, then 
select the vehicle in Device selector and click the “Detect cameras” button. The module will 
search for any connected cameras and will display the found ones. Images from up to 16 cameras 
can be displayed simultaneously. To increase or decrease the camera window dimensions, place 
the mouse cursor over the boundary between two cameras and drag-and-drop the camera 
bounding box. 

•	 The “Show camera number” option allows displaying the camera number in the camera window.
•	 The “Show time and offset” option allows showing the photo time and offset of the photo time 

from the current track point’s time.
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To display the photos, select the data to be viewed and run Track player; photos will appear during 
photo displaying in Photo viewer (Fig. 177). If no other photos were taken within an hour after the 
photo, then that photo will be displayed in Photo viewer for 1 hour. 

Fig. 177. Displaying photos. 

Fig. 176. Setup of Photo viewer. 
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The commands in the photo shortcut menu which is called by right-click on the photo allow 
going to the folder where the current photo is stored, opening the photo, etc. Also the “Rotation” 
command is available in this menu. It allows rotating the photo by the selected angle. The rotation 
angle is always counted off from the initial orientation of the photo, but not from the current one.
The point in which the photo was taken is highlighted with a special icon on the track (Fig. 178). 
The photo recording points are displayed on the track always if the photos were received from the 
gauge.

Fig. 178. Photo icons on the track. 
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PHOTO TAKING COMMAND
Using Photo viewer, the user can send a command to a AutoGRAPH gauge such as on-board 
controller or AutoGRAPH-INFO device to take a photo. For this purpose, do the following:
•	 Select the desired device in Device selector.
•	 In Photo viewer in the desired camera’s window right-click and select the “Make photo” command 

in the menu that appears (Fig. 179).
•	 Then select the type of AutoGRAPH device: AutoGRAPH-GSM if the photo is requested from the 

AutoGRAPH controller / AutoGRAPH device, or AutoGRAPH-INFO if the photo is requested from 
the AutoGRAPH information display.

•	 A command to receive the selected camera’s photo will be sent to the gauge. 

Fig. 179. Requesting a photo from camera 1. 

•	 After recording the photo will be sent to the server if the connection to the server is available. 
To download the photos from the server into the AutoGRAPH 5 PRO program, go to the “Photo 
loader” panel of the Online devices provider. 

KEY PARAMETERS FOR PHOTOS
The parameters for photos are added to Device data handler of the AutoGRAPH 5 PRO program. 
Using them it is possible to display the photo information in Data Viewers, receive reports and use 
these parameters in calculations and during data handling. 
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The key parameters for photos are described below:

Description Name/expression Comment

Photo was taken TypeID == 15 && EventID == 143 The parameter is a switch which is activated 
during recording of a new photo. The photo 
entry is calculated by the entry type and 
AutoGRAPH gauge events: the event entry is 
type 15 (TypeID), the photo entry event is type 
143 (EventID). An expression for calculating 
the parameter is provided in the “Parameter” 
column of this table. The photo entry 
parameter may have any name. This parameter 
can be used for obtaining a detailed report 
on photos by splitting the vehicle track into 
stages based on that parameter.

Camera number CameraNum The parameter returns the address of the 
camera from which the photo was taken. 
The camera address is set during camera 
configuration and AutoGRAPH gauge setup 
for operation with cameras.

Photo reason PhotoReason The parameter returns the number 
corresponding to the photo entry reason:
0 – the photo was taken based on the time.
1 – the photo was taken based on the input 
operation / based on the event.
2 – the photo was taken by request, for 
example, from AutoGRAPH 5 PRO Dispatch 
Program.

Photo time PhotoDT The parameter returns the photo entry time. It 
is also recommended to set up the parameter 
format for correct display of the time. 

Photo PhotoImage The parameter returns the photo. 

iNOTE
For details about the parameters for photos see Auto help integrated into the parameters list of AutoGRAPH 
5 PRO program. To call the Auto help, go to the “Devices” menu, then go to the settings section Calculation 
> Calculation parameters and select the “Parameters list” tab. Right-click on the parameters list and select 
the “Auto help” item in the menu that appears. 
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VEHICLE PARAMETER STATE 
INDICATION
Modules allowing indication of the vehicle parameter states are integrated into the AutoGRAPH 5 
PRO program:
•	 The “Values indicator” module displays the current states of the vehicle parameters over a time 

span or over a trip as a table.
•	 The Dashboard module indicates the current states of the vehicle parameters over a time span or 

over a trip using different scales and indicator gauges, for example, speedometers, level gauges, 
etc.

The indication is provided during the track playback and during selection of different data in 
Device selector. In the latter case the indicator modules show the latest values of the vehicle 
parameters over the selected display time span.

VALUES INDICATOR
Fig. 180 illustrates an example of the vehicle parameters indication in the “Values indicator” module.

3 module data sources are provided:

Fig. 180. Values indicator.

Autoselect – if the Device selector cursor is 
placed over the vehicle, then the data source 
is Data base with the latest data, if the Device 
selector cursor is placed over the file or data 
source (GSM, USB, etc.), then the data source is 
Trips selector and the selected trip.

Online data – Data base is the data source. 
Data base type (GSM, USB, SMS, etc.) can also 
be selected. This option is useful when several 
data bases are installed in the scheme.

Report data – the data source is the data over 
the selected trip, if splitting of the track into 
trips is enabled, or the data covered by the 
selected display time span or data file, if the 
splitting into trips is disabled.

iNOTE
The data source selection menu may be hidden. For this purpose right-click the Values indicator window, then 
de-select the check box opposite the “Source menu” option in the menu that appears. To display the menu, 
select the check box again. 



AutoGRAPH 5 PRO • USER MANUAL140

TechnoKom © 2016

To display the states of the vehicle parameters over the desired period:
•	 Select the data for displaying in Device selector.
•	 Set up the data display time span, if data is sorted based on the time span in Device selector.
•	 Select a trip for displaying in Trips selector, if the track is split into trips. 
•	 Select a desired data source in the “Source” field in Values indicator (Fig. 180).

The vehicle indicators are sorted into groups by types:
•	 actual states of inputs and flags,
•	 the latest known coordinates over the selected time span,
•	 movement state: park or movement,
•	 speed: current, maximum, medium and excessive,
•	 state of coordinates – outdated or updated coordinates,
•	 movement parameters: speed, distance, duration of the movement in relation to the zero point 

(to or from), and
•	 the source type and name, the data file name. 

iNOTE
Zero point is a conventional reference point. By default, the track start point over the selected calculation time 
span is considered to be the reference point. The user may monitor with respect to the zero point which can 
be set by him on any track segment by “Ctrl+double click” key combination (double click of the left mouse 
button). 

DASHBOARD MODULE
Fig. 181 provides an example of Dashboard module.

Fig. 181. Dashboard module.
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The Dashboard module can show:
•	 The actual state of the vehicle parameters over the selected time span. If the data is sorted by 

files in Device selector, then Dashboard module displays information over the time span covered 
by the selected week file. If sorting is carried out by the time span, then Dashboard module 
displays the information over the time span specified in Time span selector.

•	 The actual state of the vehicle parameters over the selected trip, if the data is split into trips in 
Trips selector. 

•	 The online data, if the Device selector cursor is placed over the vehicle header.
•	 The current state of the vehicle parameters during playback of the track. 

ADDING OF A NEW INDICATOR/GAUGE
Editing of Dashboard module is carried out in the settings mode. The settings mode allows 
adding new elements to Dashboard module, delete and move elements, set up the properties 
and parameters of the Dashboard module elements. In the settings mode the additional menu at 
the top of Dashboard module is available. It contains Dashboard module settings (Fig. 181, item 1). 
To switch into the settings mode, right-click on Dashboard module and select the “Settings mode” 
option. To quit the settings mode, re-select this option, or click the  button.

There are two types of indicators in the module:
•	 Gauge designed for displaying the quantitative value of a parameter, for example, speed or fuel 

level value, etc.
•	 Values indicator designed for displaying the states of switches, for example, for displaying 

overspeeds, sensor operations, etc. 

To add a new parameter:
•	 Call the settings mode.
•	 In the settings mode go to the “Add” menu and select an indicator – a gauge or a state indicator 

in the list that appears. The “Blank space” option allows adding a blank space as a boundary to 
Dashboard module, for example, between two indicators. When the “Gauge” and the “Values 
indicator” options are selected, an additional menu appears in which the user may select the 
desired indicator type. 

•	 Then set up the added element. For this purpose, open the “Gauge customization” menu by 
clicking the “Customization” button on the module toolbar, then select an element to be set up 
(Fig. 182). 

•	 The following parameters shall be set up for correct operation of the element:
•	 In the “Parameter” field select the vehicle parameter which state will be indicated using this 

indicator. For the state indicator it is sufficient to set a parameter for indication. For a gauge it 
is necessary to set the additional settings. The information about the gauge setup is provided 
below.

•	 Set the element range specifying the minimum and maximum values. “Set min and max values 
from parameter” option allows using the range of values for the parameter the state of which 
is displayed by the indicator.
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Fig. 182. Setup of dashboard module element.

•	 Set up the scale parameters: Set up the division factor in the “Divider” field, the number of the 
major and intermediate scale divisions. 

•	 Set up the indicator label. Using Up, Down, Left and Right buttons located under the label 
setting field, the user may customize the label position on the gauge. 

•	 In the setup mode the size of the gauge or values indicator can be set up. For this purpose 
right-click on the indicator to be set up, and select the “Size limit” option in the menu that 
appears, then select the limit option. To change the non-fixed size, place the mouse cursor over 
the contour line of the element and move it. 

•	 To delete an element, right-click the selected element and select the “Delete current” in the 
menu that appears. To delete all elements of Dashboard module, select the “Delete all” option. 

•	 When setup of the indicator is completed, close the setup menu and save the changes by clicking 
the “Save” button (Fig. 182) on the module toolbar. 

•	 The “Restore” button (Fig. 182) allows applying the latest saved configuration of the Dashboard 
module.

The Dashboard module background color may be changed. For this purpose, select the desired 
color in the “Back color” palette on the Dashboard module toolbar (Fig. 182). A pattern can be 
applied to the background instead of the color. For this purpose, select the desired pattern in the 
“Pattern” list on the Dashboard module toolbar. 
The Dashboard module configuration can be saved to an external .xml file. For this purpose, right-
click the Dashboard module, and select the “Save to file...” command in the menu that appears. 
To load the configuration from an external file, right-click on the Dashboard module and select the 
“Load from file” option in the menu that appears. 
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TRACK PLAYBACK
The Viewer player is integrated into the AutoGRAPH 5 PRO program. It allows playing back the data 
in viewers. The player plays back the monitoring on-board controller’s entries chronologically, thus 
allowing restoring of the vehicle movement history over the desired time span. 

GENERAL INFORMATION
All AutoGRAPH 5 PRO program viewers are connected to the Player. During playback the vehicle 
cursor moves along the track reproducing the vehicle parks. In the display modules – in the 
Dashboard module and in the Values indicator – the current value of the vehicle parameters 
is displayed. The Chart Viewer cursor moves to the graph point corresponding to the current 
playback point. If Stages viewer and Data Viewer are synchronized with Player, then during the 
playback the viewers’ cursors move with Player. To synchronize the viewer, right-click the desired 
viewer and select the “Synchronize with player” command in the menu that appears (Fig. 183).  

Fig. 183. Synchronization of viewers with the player.

PLAYBACK SETTINGS
Prior to playback it is recommended to set up Player. Settings are located the right of the playback 
buttons in Player (Fig. 184).

Fig. 184. Player settings.
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The “Speed” menu allows selecting the data playback speed.
The “Skip parks” option disables stopping of the vehicle cursor on parks. 
The “Auto repeat” option allows re-start the playback of the data over the selected time span after 
completion of the playback. 
The “Settings” menu allows setting up the following parameters (Fig. 185):

Player range is the playback range in case of splitting the data into trips:
•	 Whole calculated time span – play back the whole selected calculated time span. In this case the 

Trips selector cursor will move along the trips list in synchronization with the player.
•	 Current trip time span only – play back the data only over the current trip.  

Multiple trip selectors – playback parameters, if several Trips selectors are installed in the scheme:
•	 Time span overlap with alignment on start – the data of different Trips selectors is played back 

simultaneously, and the start points of the time spans are being aligned. 
•	 Single time span – all selected time spans are played back successively in chronological order, i.e. 

first the earliest trip is played back, then the second one, etc.

Fig. 185. The “Settings” menu of the Player. 

DATA PLAYBACK
To play a track:
•	 Select the data for playing back in Device selector.
•	 If the data in Device selector is sorted based on a time span, then set up the display time span in 

Time span selector.
•	 Select a trip for playing back in Trips selector.
•	 Start the player by clicking the “Playback” button. To control the playback, it is recommended to 

use the buttons located on Player:

Start
Go to start of calculated time 
span.

Back
Go to the previous point.

Play back
Start player. 

Forward
Go to the next point. 

Finish
Go to end of calculated time 
span.
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•	 In the playback mode the playback time span is displayed on Player – date and time, as well as 
date and time of the current playback point.

•	 In addition, the indicator shows the current point parameters in the left bottom corner of the 
map (Fig. 186).

Fig. 186. Playback display.

•	 Moving the Player slider bar, the user may manually select the data for playback.

The player may be set up to automatically play back the online data after downloading from the 
server. To enable this option, go to the Player section in the “Options” menu, select the “Operations” 
tab and select the check box for the “Start playback after receiving online data” option (Fig. 187). 

Fig. 187. Setup of automatic data playback. 
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ZERO POINT
The zero point allows setting a custom reference point. To set the zero point, use the “Ctrl+double 
click” key combination on the desired track point. When playing back and displaying the track the 
counting of the vehicle parameters such as distance, consumption data, etc. will be carried out 
from the track start and from the zero point (Fig. 188). 

Fig. 188. Zero point referencing.

To remove zero point, set the track start point as the zero point (there is the “Start” button which 
allows quick moving of the vehicle cursor to the track start). 

The AutoGRAPH 5 PRO program allows setting the data display time span based on the current 
vehicle cursor position. For this purpose:
•	 Set the zero point on the desired track point.
•	 Set the vehicle cursor to other track point. The cursor can be set both before and after the zero 

point. The vehicle cursor is moved by the double click.
•	 Right-click and select the “Set period by vehicle and zero point” command in the menu that 

appears (Fig. 189). The time span limited by the zero point and the vehicle cursor will be set in the 
program, and the vehicle cursor being moved to the track start point (Fig. 190). 

Fig. 189. Setting the display time span based 
on the vehicle and zero point.

Fig. 190. Display time span based on the 
vehicle and kilometer zero.
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ENTRIES LIST
The entries made by AutoGRAPH controller / AutoGRAPH device (or a third-party terminal 
transmitting data to AutoGRAPH Server) are displayed in Data Viewer. These are coordinate entries, 
readings of sensors, inputs, etc. Also, the parameters calculated by Device data handler of the 
AutoGRAPH 5 PRO program are displayed in Data Viewer.  

DATA SOURCE

Several data sources are provided for Data Viewer. A data source can be selected in the “Source” 
field (Fig. 191, item 1):
•	 Autoselect – in this case, if the Device selector cursor is placed over the vehicle, then the calculation 

source is Data base (with the latest data), if the Device selector cursor is placed over the file or 
data source (GSM, USB, etc.), then the data source is Trips selector and the selected trip.

•	 Online data – Data base installed in the scheme base is the data source. This option is useful 
when several data bases are installed in the scheme. When selecting this source the user can 
also select the Data base type and the maximum quantity of entries for display (Fig. 192).  

Fig. 191. Data Viewer.

Fig. 192. Data source – Online data. 
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When the “Auto” value is selected in the “Entries max.” field, the online data will be calculated 
according to the online data set for the online calculation, rather than based on the quantity 
of entries. For details about setup of the online calculation see section “Online and offline data”. 

•	 Report data – the data source is the trip selected in Trips selector, if the data is split into trips, or 
the data covered by the selected time span or data file, if the splitting into trips is disabled. 

When a data source is selected in Data Viewer, the entries from that source and the parameters 
calculated by Device data handler based on the controller entries are displayed. The “Files” tab 
contains a list of files covered by the selected time span or trip. The additional tabs of Data Viewer 
can be shown / hidden by clicking the “Statistic” button in the right upper corner of the viewer 
window (Fig. 191, item 2). 

The quantity of entries in the file, the 
number of the first and last entries and the 
time range covered by the file are indicated 
on the “Files” tab for each file (Fig. 193). 
To go to the first file entry, double-click 
with the left mouse button on the file, or 
right-click and select the “Go to initial entry” 
option in the menu that appears. To go to 
the final file entry, right-click on the file, and 
select the “Go to final entry” in the menu 
that appears. 

Fig. 193. Files list. 

The boundary between the files is represented by a horizontal line in the entries list. For details 
about the entries list colouring see “Entries list colouring” section. 

ENTRIES LIST
The entries list (Fig. 191, item 3) is presented as a table where rows are entries of the on-board 
controller (coordinate entries, readings of sensors, external sensors, etc.), columns are the vehicle’s 
parameters received from the controller and calculated in the program.
The entries list read from the selected data source is provided on the “Statistic” tab (Fig. 194). The 
user can selectively hide some types of entries. For this purpose de-select the “Show” field of the 
respective entry. 
All types of entries can be shown or hidden by right-clicking on the entries list and selecting the 
“Show / hide all types” option in the menu that appears.
The “Hide all types but current” option in the same menu allows hiding all types of entries except 
the selected one. 
The “Hide intermediate entries” option allows hiding any intermediate entries, for example, the 
new file start entry.
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Fig. 194. Files list. 

Each entry in the entries list has an index consisting from the trip number to which the entry refers, 
the file number from the selected source in which the entry is stored, and position of the entry in 
the file. 
By default the indexes are hidden. To show the indexes, right-click the entries list and select the 
“Indexes” option in the menu that appears. Re-selection of the option hides the indexes. 
The vertical line repeating the track colouring is displayed with the trip number in the “Trips” 
column. 

Fig. 195. Entries indices. 
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The indexes allow synchronizing the entries in Data Viewer with the data in other viewers. Left 
double-clicking on the entry places the cursors in other viewers to the entries corresponding to 
the entry selected in Data Viewer. 
Also, Data Viewer can be synchronized with Player. It allows automatic movement of the Data 
Viewer cursor with the Player. To allow the synchronization, right-click the entries list and select 
the “Synchronize with player” option in the menu that appears. 

FINAL PARAMETERS
Data Viewer allows calculating the final parameters of the vehicle over the selected display time 
span. The final values are displayed in the “Final parameters” section of Data Viewer (Fig. 191, item 
4). 
For Device data handler to be able to calculate the final parameter value, that parameter shall be 
included into the “Final” list (Fig. 196). The setup is carried out in the “Devices” menu. 

Fig. 196. Final parameter.

ENTRIES LIST COLOURING
Data Viewer in the AutoGRAPH 5 PRO program offers the entries colouring capability. The colouring 
parameters can be set up in the section Appearance > Entries list colouring of the “Options” menu 
(Fig. 197). 
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Fig. 197. Entries list colouring setup. 

The colouring can be performed using the following methods:
1.	Vertical lines, if the readings level increase is detected. An example of the vertical lines is shown 
in Fig. 198, item 1.
2.	The vertical lines, if the readings level decrease is detected. An example of the vertical lines is 
shown in Fig. 198, item 2.
3.	Horizontal lines, if there are any hidden rows, for example, if some types of entries are hidden 
(Fig. 198, item 3).

Fig. 198. An example of entries colouring in Data Viewer.
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4.	A horizontal line at joint of two data files (Fig. 198, item 4). The files joint can occur when the data 
is displayed over a time span, when the time span covers several data files.
5.	The cell text colouring, if the cell value was not updated during the latest data entry (Fig. 198, 
item 5).
6.	The cell text colouring, if the parameter value was filtered out (Fig. 198, item 6). 
7.	Colouring of a cell outline with date and time, if the entry was made on a holiday – Saturday and 
Sunday (Fig. 198, item 7). 
8.	Colouring of the whole entry row based on the vehicle parameter triggering. To color the 
entries list by parameter triggering, set the parameter for colouring – a name or an alias in the 
“Parameter name for colouring rows” field in the section Appearance > Entries list colouring of the 
“Options” menu (Fig. 197). If this parameter was enabled, then the entry made at that time will be 
highlighted with the color which was set for the enabled state of the parameter in the settings 
of that parameter (in the list of parameters in the “Devices” menu). Fig. 199 (item 1) illustrates an 
example of the entries list colouring based on triggering of the overspeed parameter.  

9.	Colouring of a column with the color set for the parameter graph. To enable colouring of 
columns, go to the section Appearance > Entries list colouring in the “Options” menu and enable 
“Colouring the column by parameter” option on the “Highlighting” tab (Fig. 197). An example of 
entries list columns colouring is shown in Fig. 199, item 2.

Fig. 199. An example of entries colouring in Data Viewer.
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PRINTING AND EXPORTING ENTRIES LIST
Export of entries list
The entries list can be exported to external files. For this purpose, right-click the entries list and 
select the “Export to” command in the menu that appears. Then select a format of the file to which 
the list will be exported. After export the final file will be opened automatically.

Copying the entries list via the clipboard
The desired entries list rows may be copied to the clipboard and pasted to an external file. Then 
right-click the entries list and select the “Copy selected rows” command in the menu that appears. 
The selected table rows will be copied to the clipboard from where these rows can be pasted to 
any file.
For this purpose, select the desired rows. Selecting several rows is carried out using “Ctrl+left 
click”1 or “Shift+left click”1 key combinations. 
The rows can also be copied using the “Ctrl+C” key combination.

Print of entries list
The entries list can be printed. To print the entries list, right-click the list and select the “Print” 
command. After that a printed list preview window will appear in which the user can set up the 
paper size and other print properties. To send a file to printer, in preview mode select File > Print...

1 Left click is a single click of left mouse button. 
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OBJECTS PROPERTIES
This section of User Manual describes operation with properties for different objects of the 
AutoGRAPH 5 PRO program such as devices, geo-fences, drivers, field processing implements, etc.
The elements properties include various tare tables, object aliases, types, vehicle certificate data, 
constants, etc. 

VEHICLE CARD
The vehicle card allows storing the vehicle certificate data. The card data can be used as reference 
information in reports and Data Viewers. 

Fig. 200. Vehicle card.

An example of Vehicle card is provided in Fig. 200. To fill in the vehicle card, go to “Devices” menu. 
The vehicle card is filled in individually for each vehicle and is not available for a vehicle group. So, 
choose a device in the “Devices” menu, then go to the settings section Properties > Vehicle card and 
fill in the card (Fig. 201). 
•	 Some card fields can be set for a vehicle group. In such a case a property will be added to cards 

of all parent group’s vehicles, except those vehicles for which that property is individual one. The 
property will also be added to the parent group’s properties registry. To apply the card property 
for all vehicles of the group, fill in the field and select the “Set for whole group” command in the 
shortcut menu of the field. The shortcut menu is called by clicking the  button. 

•	 To assign a value set to the whole vehicle group to a property, select the “Inherit from group” 
command in the shortcut menu of the property. When the value of the property set for the whole 
group changes, this property will also change in the cards of the devices inheriting that property 
from the group.
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•	 To make the property individual for a vehicle, rather than inherit it from the group’s properties 
registry, select the “Set for vehicle individually” command in the shortcut menu of the property. 

The properties added to the vehicle card are added to the properties registry of that vehicle. 
Automatic adding of the card properties to the registry can be set up in the program. If automatic 
adding of properties is disabled, then after editing of the card click the “Set” button to add the card 
parameters to the properties registry. 
To set up the automatic setting of the properties, go to the section Properties > Autoset settings 
of vehicle card in the “Options” menu and select the check box for the “Automatic setting of 
parameters” option (Fig. 202). 

Fig. 201. Editing Vehicle card.

Fig. 202. Automatic setting of Vehicle card parameters.
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PROPERTY CARD
The vehicle card allows adding only a particular data set to the program. To add custom properties 
of objects, the “Property card” module is provided in the program. The structure of Property card is 
fully determined by the program user. 

For each program object such as geo-fences, devices, implements, drivers, etc. an individual 
property card can be set up. The card is set up on the “Card elements collection” tab in the section 
Properties > Property card of the “Options” menu. 

Fig. 203. Editing Property card.

The Property card setup menu is a constructor allowing adding custom property types to the 
module and arranging them in a random way in the module window.
To set up the Property card type, select an object to which the Card properties will refer to in the 
“Apply to” field (Fig. 203, item 1):
•	 Devices – to create the vehicles’ property card.
•	 Geofences – to create the geo-fences’ property card.
•	 Drivers – to create the drivers’ property card.
•	 Implements – to create the field processing tools’ property card.
•	 Tasks – to create the tasks’ property card. 
The card properties will be stored in the properties registry of the object to which such properties 
are applied. 

Once the type is determined, new elements can be added into the card. To add a new element:
•	 Go to Constructor mode by right-clicking on an empty card area and selecting the “Customize 

layout” command. The “Customize” menu will appear (Fig. 203, item 2).
•	 Click the “Add” button (Fig. 203, item 3), and select an element for adding in the list that appears.
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Fig. 204. Vehicle Property card.

Fig. 204 illustrates an example of the Vehicle 
property card. The Vehicle property card is 
filled in the “Devices” menu. 

•	 Select the new element’s arrangement in the Property card window.
•	 Set up the element parameter in the “Customize” menu: Property name, Tooltip, minimum and 

maximum values, highlighting of the property in Vehicle card, display of floating point numbers 
and the property value list (child items). Depending on the property type, some parameters 
may be unavailable for editing. Right-click on the card element displays the menu in which the 
additional element editing commands are available.

•	 Similarly, add other properties to the Card and set up their parameters.
•	 Quit the Constructor mode. For this purpose, close the “Customize” menu. 
Once the card structure is determined, the user may edit property values in the respective menus 
of the program. 
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PROPERTIES REGISTRY
The Properties registry stores different object parameters, properties added to the Property card, 
tare tables, reference data, etc. The modules of AutoGRAPH 5 PRO program can access the object 
properties by reading them from the Properties registry. 

The Properties registry operation procedure is described below based on the example of the 
vehicles’ Properties registry. The provided information is also valid for other AutoGRAPH 5 PRO 
program objects such as geo-fences, drivers, implements, etc. To edit the vehicle’s Properties 
registry, go to the section Properties > Properties registry in the “Devices” menu (Fig. 205). The 
properties list is presented as a table. 

Fig. 205. Vehicle Properties registry. 

The Properties registry allows setting up the property validity time, and also setting up several 
property values and limit the validity time of each one. It allows, for example, assigning the vehicle 
drivers setting up the operation time of each of the drivers. 

PROPERTY TYPES
The AutoGRAPH 5 PRO program supports the following property types:

String – allows storing names and aliases of objects, file names, etc., for example, vehicle names 
which may be used in reports and viewers.

Number – allows storing numeric values.

Date – allows storing dates. 

Time – allows storing time.

Text – allows storing text messages.

Color – allows storing the object colour. 

Boolean – allows storing boolean values “Yes” or “No”.

Tare table is designed for storing tare tables of different sensors.
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Geo-fence is designed for storing the list of geo-fences. When the geo-fences parameter is set up, a 
value of such a property from the registry may be assigned to this parameter. 

Driver is designed for storing the list of drivers. 

Implement is designed for storing the list of agricultural tools. 

CREATION OF A NEW PROPERTY
To add a new property to the table:
•	 Place the cursor over an empty string in the “Name” field and set the property name.
•	 Set a property type. The property types are described above.
•	 Set the property value in the “Value” field or set up the value table. The value table allows setting 

several property values and setting up each value’s validity time. For details about the value table 
setup see below.  

To delete a property, click the “Delete property” button in the “Name” field of that property.

SETUP OF THE VALUE TABLE AND TIME RANGE 
To set up the property value table, click  button in the “Value” field, and list all values of the 
property to be set up in the menu that appears (Fig. 206). If required, set up each value’s validity 
start and end time. In the “Comment” field the user may enter any comments and remarks. 

Fig. 206. Property value table.

When setting up the value validity range, please note that:

•	 The ranges may contain the initial and final time. In this case the property value will be absent 
between the ranges.

•	 The ranges contain only initial time. The end of such a range will correspond to the next range’s 
start. 

•	 The initial range can contain neither initial, nor final time. The first value of the property will be 
actual till the start of the second range. 

•	 The final range may contain only initial time. In this case the latest value of the property will be 
actual till the current date. 

iNOTE The time intervals of the vehicle property value do not depend on the time zone set for that vehicle. 
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GROUP EDITING OF A PROPERTY
For convenience of operation with the property list, group editing of a property for the whole 
vehicle list is provided in the program. 
To go to the group editing of a property, click the  button in the field with name of that property. 

Fig. 207. Group editing of a property.

In the group editing mode the user may edit the property values for each vehicle for which that 
property is added, and set up the value validity time.
The current property value set for the vehicle is displayed in the “Value” field. This value is valid 
from the date indicated in the “Start date” till the date indicated in the field “End date”. 

PROPERTY ALIASES
To properly import data from 3.0 or 4.0 version of the AutoGRAPH program to AutoGRAPH 5 PRO, 
set up aliases of some properties in the AuroGRAPH 5 PRO program. For this purpose, go to the 
section Properties > Property aliases in the “Options” menu and set up:
•	 the property name containing the vehicle alias,
•	 the property name containing the device working zone radius, in meters.

Fig. 208. Setup of properties aliases.
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SEARCH IN DATA
For convenience of operation with a large amount of data, the search module is integrated into the 
AutoGRAPH 5 PRO program. It allows searching for the required data in Data base.
In the current version of the program the Finder module only supports searching for geo-fences 
passed by vehicles. 

Fig. 209. Search module.

To search for the passed geo-fences:
•	 Select a vehicle to be monitored in the module’s Device selector.
•	 Set up the time interval over which the search will be carried out.
•	 In Geofence selector, select geo-fences the passage of which is to be checked. To select geo-

fences, display of check boxes shall be enabled in Geofence selector. 
•	 Click the “Search” button in the left bottom corner of Search module.
•	 The module will carry out search based on the set criteria and will display the results (Fig. 209). 
•	 Clicking on tool  in the results list in the program will set th Finder settings; the time when the 

vehicle enters the geo-fence will be shown in the viewers.
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EVENT LOG
The event log is integrated into the AutoGRAPH 5 PRO program. All important system events are 
recorded into it. The event log opens automatically when the program opens. The log may be 
called manually by clicking the “Event log” button in the right bottom corner of the program (Fig. 
210).

Fig. 210. Display of Event log.

An example of the Log contents is illustrated in Fig. 211. 

Fig. 211. Event log.

The events recorded into the Log may have different importance levels. The experiences users 
may set up the logging level. To set up the Log, go to the folder into which the AutoGRAPH 5 
PRO program is installed, then find file nlog.config in this folder. That file contains the Event log 
configuration. 

To set up logging, it is sufficient to set the following parameters in that file:
•	 Indicate the path to the folder into which the log file will be saved. For this purpose, in nlog.

config file add the following string to section <targets>: <target name=“AGShell” xsi:type=“File” 
fileName=“${tempdir}\AGShell_${date:format=yyyyMMdd}.log”. If such a string is already present, 
it is sufficient to edit it. In the field fileName= set the full name of the file to which the log will be 
recorded. The full name is the path to that file and the file name separated by “\” symbol. In the 
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simplest case the file location is set using a label placed between ${}. The label should be inside 
the braces. After the label enter “\” symbol and indicate the file itself for the log recording. The file 
name can also contain labels, for example date labels so that the current date be indicated in the 
name. For example, when setting up fileName=“${tempdir}\AGShell_${date:format=yyyyMMdd}.
log” the log will be saved to a temporary system folder (for MS Windows 7 OS it is \Temp folder in 
the current PC user’s directory), to file AGShell_yyyyMMdd.log, the current date being indicated 
in the file name instead of yyyyMMdd. 

•	 Then indicate the logging level. For this purpose, in the nlog.config file add string <logger 
name=“AGShell” minLevel=“Info” appendTo=“AGShell”/> to  <rules> section. If such a string is 
already present, you may simply edit it. The minimum logging level is set in the minLevel= field, 
for example, minLevel=“Info”.

•	 The following logging levels are provided (in the priority ascending order):
Trace is a very detailed log which can contain a large volume of information. Such logging level 
is more frequently used by the developers. 
Debug is the debugging information, less detailed than at Trace level. The Debug is usually 
disabled in the finished product
Info is information messages which are usually allowed in the canned software. 
Warn is warning messages. As a rule, they are used for non-critical errors and temporary software 
failures which can be corrected. 
Error is error (most often exception) messages. 
Fatal is fatal error messages. 

The logging levels are listed in the priority order. The minimum logging level allows logging of 
event with a higher priority level. It means that at Info logging level all Info, Warn, Error and Fatal 
level events will be logged. 

The AutoGRAPH 5 PRO program log is built on Nlog platform. For details about the platform 
and configuring file nlog.config visit website https://github.com/NLog/NLog/wiki/Tutorial. The 
section “Configuration” of this page contains an instruction for full logging setup. For details 
about methods of setup of the log file locations see “Layouts” section of the same page. The page 
https://github.com/NLog/NLog/wiki/Layout-renderers contains an instruction for setup of the full 
file name using labels.

LOGGING CHANGE OF SETTINGS
The AutoGRAPH 5 PRO program logs the vehicle settings change to a separate log – ProgramData\
AutoGRAPH Shell\ SettingsLog.db3.  To set up the settings log, go to the “Options” menu of 
AutoGRAPH 5 PRO, to the section Vehicle control > Settings logger (Fig. 212).
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Fig. 212. Settings log setup.

•	 To log the settings changes, enable the “Commit changes” option (Fig. 212). 
•	 The user may select the log entries storage time in the drop-down list “Delete records older than”. 

By default records older that 3 months are deleted automatically. 

The display of the Settings log contents using the program facilities is not available in the current 
AutoGRAPH 5 PRO program version. 
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LIST OF TERMS
AutoGRAPH 5 WEB A web version of the AutoGRAPH 5 dispatcher software installed 

on AutoGRAPH server and allowing the access to the data from 
any device (PC, tablet computer, telephone, etc.) connected to the 
Internet, using a web browser.  

Data base The \Data folder on the local computer with the installed AutoGRAPH 
5 PRO program in which the data received from AutoGRAPH gauges 
is stored. Each gauge’s data inside the \Data folder is sorted into 
separate folders according to serial numbers.  

Driver The person operating the vehicle and identified in the program using 
a personal key or card (iButton, RFID, driver card for tachograph, 
etc.).

Geo-fence A virtual zone on the map which allows monitoring the passage 
of important route segments by a monitored object by means of 
registering the points of entry and exit to/from such segments. The 
geo-fence monitoring feature allows real-time registering the arrival 
of a monitored object to the key route segments and checking that 
object’s parameters inside such segments, for example, speed, 
distance, the time spent inside the geo-fence and other parameters 
determined by the configuration of the AutoGRAPH 5 program 
scheme.

Event log A log designed for recording important events, notifications and 
errors occurring during operation of the AutoGRAPH 5 PRO Dispatch 
Program. 

Vehicle image The image used for designation of the vehicle on the map, in reports 
and in the trips selector. 

Implement Any implement installed on the vehicle. Implements are used in 
the AutoGRAPH 5 PRO program for calculation of the area of the 
territory processed by the vehicle.

Map A geographic map (online, vector or raster) integrated into Map 
Viewer and designed for displaying the vehicle location at selected 
time, vehicle track, track segments and geo-fences. 
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Constructor A special program integrated into AutoGRAPH 5 PRO dispatcher 
software and designed for setting modules and creation of a 
working scheme of the Dispatch Program.

Vehicle cursor A special pointer pointing the vehicle location on the map at 
selected time, and the vehicle movement direction.

Mobile check point A monitored object moving slowly or changing its location 
seldom in relation to other objects. It is used as a check point for 
determination of the time of approach of other monitored objects 
to that point and objects’ parameters at this time. 

Module A separate application, built-in or supplied with AutoGRAPH 5 PRO 
Dispatch Program and designed for execution of particular tasks in 
the dispatcher software and connected to the program modules for 
data exchange during processing.

Multi trips (multi tracks) The mode allowing displaying the tracks of several vehicles on the 
map, one vehicle being the main, and the additional vehicles’ tracks 
are generated in relation to the main vehicle’s track.

Monitored object A vehicle, stationary object, human or a pet equipped with the 
AutoGRAPH gauge which monitors the object’s movement, and 
checks and records the movement and operation parameters. 

Operative group A group of monitored objects having a high importance status and 
requiring permanent display of the current location on the map. 

Stage A stage, the start and end of which are determined by the state of 
the particular parameter of the monitored object. 

The user of the AutoGRAPH 
5 PRO program

The user registered on the AutoGRAPH server allowed to access the 
data on the server according to login and password, and the list of 
allowed gauges and having a particular role in the AutoGRAPH 5 
PRO Dispatch Program.
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AutoGRAPH gauge An on-board or personal AutoGRAPH monitoring controller, and the 
security beacon AutoGRAPH-ST designed for installation onto the 
monitored object, registration of movement, recording of operating 
parameters of the object and transmission of the accumulated 
data to the AutoGRAPH Server via GSM (GPRS) network or Wi-Fi, 
depending on the controller modification. 

Desktop The configuration of the AutoGRAPH 5 PRO program working area 
determining arrangement of modules, window sizes, tab types, etc. 

Trip A vehicle’s working time span the start and end of which are 
determined by the trip splitter settings. The trip may be limited by a 
time interval, vehicle (sensor) parameter state change, or generated 
as the driver’s identification key is registered. 

Role A particular set of access rules assigned to the user of the AutoGRAPH 
5 PRO Dispatch Program and allowing limitation of the user access 
to different sections and menus of the Dispatch Program. The role 
settings are determined by the scheme. 

AutoGRAPH Server The AutoGRAPH server software designed for request-based 
reception, storage and transmission of data from gauges to the 
AutoGRAPH Dispatch Program. From server software version 4.0, 
the access to the data stored on the server is provided based on the 
individual user login and password.  

Stationary object A monitored object with fixed coordinates equipped with an 
AutoGRAPH gauge recording and monitoring parameters of this 
object’s operation. 

Scheme A configuration of the AutoGRAPH 5 PRO program including a 
particular set of modules, a list of monitored objects and their 
settings, a list of geo-fences, drivers, implements, etc.

Vehicle Any vehicle and freighter or passenger carrier with on-board 
AutoGRAPH gauge which monitors movement of that vehicle and 
records its operation parameters. 
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Track A vehicle movement path over a custom time span restored by the 
coordinate entries of the AutoGRAPH gauge in chronological order.

Data file A .sbin or .bin format file containing entries of the AutoGRAPH 
gauge loaded into Data base of the AutoGRAPH 5 PRO program via 
the server or read from the gauge memory via USB.
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